Launcher not rendering/black screen upon clean install

I am trying to run doomsday on a Windows 11 pro (10.0.22621) with a Ryzen 5 5600x and RTX 3090. Upon launching the executable (whether it be versions 2.3.1, 2.3, 2.0, x86, x64 architecture, or zip, or msi installer), the launcher loads with nothing being rendered. It is a black screen. However, buttons appear to work, and clicking on where buttons are supposed to be shows ui elements.

When clicking where the exit button should be, the application exits and states: 39etc665alo2.png.
I also cannot enter verbose logging mode.

Black screen:

Unrelated audio errors:

UI elements showing as if there was no black screen:

I have tried restarting my pc, updating it, updating my gpu drivers, and trying different architectures and versions of doomsday.


  • I've never tried Windows 11 so there could always be some issue specific to that, but this sounds like something is hanging during the initial search for data files.

    Have you at some point before this successfully run Doomsday? In any case, it might help if you delete the folder "C:\Users\<YourName>\AppData\Local\Deng Team\Doomsday Engine\runtime". This will ensure that the next time you launch, it will really be a clean launch with the defaults settings.

    (Note that your savegames are stored in that folder.)
  • I have ran it before on this computer, but only once. After that initial run I started to face these issues.

    Deleting the runtime folder worked perfectly, however! I tried looking for an appdata folder before, but I was looking for "Doomsday" and not "Deng Team".
    After truly clean launching doomsday, the app ran just fine.

    Thank you so much!
Sign In or Register to comment.