Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

CTD when traversing levels in Sigil and Doom Classic Music mod loaded.

I just happened to have the doom classic music mod loaded when trying out Sigil with the `.ded` provided by Skyjake. All golden... except when I activate the Baron wall mural at the end of the first map it crashes to destop (segmentation violation). While this problem is resolved rather easily by simply disabling the classic music mod (it's not used with Sigil anyway) I believe this is still a doomsday2 issue (at the minimum, a CTD indicates the need for better error handling in the specific case).

From the logs (attached), it looks as though doomsday attempts and fails to delete the existing vorbis buffer file, and then segfaults when it cant create a new one with the same name as it attempts to start the new level. Why this only shows up with the classic music mod loaded I'm not sure. It does not happen with Skyjake's music remix mod loaded.


  • Do you mean the "DOOM Classic Music" PK3 found on the Addons page?

    I couldn't see anything obviously wrong in the log you posted (no mention of vorbis/ogg files?), so I'll need to find some time to run a few tests myself.
  • Yep... that's music pack I'm talking about. I checked the log above and you're right... the lines I'm refering to aren't in it. Strange... i may have pasted the wrong log or something.

    Here is a copy and paste of the error from the Exception dialog that opens after the CTD. Line 3727 is where the first error occurs... and it CTDs very quickly after that:
    [AudioSystem] Starting music "inter" looped
                  Failed to replace dd-buffered-song1.ogg: existing file could not be removed.
    [RemoveError] (in DirectoryFeed::destroyFile) Cannot remove "dd-buffered-song1.ogg" in directory "E:\
    [Loop] Uncaught exception during loop iteration:
           [OutputError] (in NativeFile::output) Failed to write E:\_temp\WolferzTemp\doomsday-7088\
           dd-buffered-song1.ogg (No error)
           Application terminated due to exception:
    Uncaught exception during loop iteration:
    [OutputError] (in NativeFile::output) Failed to write E:\_temp\WolferzTemp\doomsday-7088\
    dd-buffered-song1.ogg (No error)
        [ > ConfigProfiles > Profiles] Wrote "/home/configs/renderer.dei" with 1 profile
    [Loop] Unloading game...
           Game ended
        [ > PackageLoader] Unloading 7 packages
    [Loop] Restoring original display mode due to shutdown

    In this specific case I "force loaded" (after disabling most of the mods i had been using) a save from just before the end of E5M9 and simply stepped through the door. The problem is extremely reproducible for me. I have also tried with a fresh start of the game with only the sigil.wad (1.1), your sigil.ded, and the jdoom classic music pk3 loaded and get the same error... so force starting without the mods the save was created with is not related.

    I should probably test it with the latest sigil.wad too... ::checks:: yep, fresh start with SIGIL_v1_21.wad and the jdoom classic music pk3 loaded (and without the ded... apparently Mr. Romero added a DD_DEFNS entry to the wad)... CTD when transitioning levels.
  • The errors in the log remind me of a previous bug where temp files weren't cleared so they kept accumulating and ultimately the old files conflicted with newly started sessions. I recall this was particularly an issue on Windows.

    Have you tried deleting all the doomsday-* folders in your temp folder? This should be done while Doomsday is not running.
  • edited 2019 Oct 4
    Just tried it... CTD'd again, same errors.

    Just for clarity: even with the Sigil wad and jdoom classic music pack loaded I don't get CTDs in any of the first four episodes... only when traversing levels in episode 5 (Sigil).
  • edited 2019 Oct 5
    Well, I tried to reproduce this issue on my Windows dev machine using 2.2 but it does not occur for me. You seem to have a custom temp file directory, though? Is it on a different drive vs. Doomsday's runtime folder?

    EDIT: According to the log file, yes. Suppose I could try this configuration, however this issue does not seem super urgent so let's see if/when I have the time.
  • edited 2019 Oct 7
    Sounds good to me, just wanted to let you know. I do have my temp folder on a different logical drive. My system partition is an SSD... a rather old one at that. So I'm leery of using it for temp storage. Especially since I do a lot of work with Photoshop, Illustrator, and Premier. Instead I've moved my temp folder to a 6-drive RAID0 array. In any case, thanks for the suggestions. I'll let you know if I find anything else.
Sign In or Register to comment.