Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Music Playback issues in Doomsday 2.1

I've been testing a bit in Doomsday 2.1, looks great! I've noticed a couple of issues with the music in this version, though.

-The IDMUS cheat doesn't appear to work (at least in Doom II), any selection comes back with an "Impossible selection" message.
-I see FluidSynth has been added to the Windows version of Doomsday. I go to select a soundfont (.sf2) but it doesn't appear to save the selection and defaults to no selection, and because of that, no music plays.
-How long as the FMOD plugin been broken for music? It works for sound effects, but for music, all I hear are these popping sounds.
-The only plugin for music playback that seems to work in Doomsday is the SDL Mixer, but there's some issue here where the opening instruments of a song seem to not play at the beginning of a track.

Thanks!

Comments

  • I'll make a note to fix IDMUS.

    I assume you are talking about MIDI (original MUS) music, and not any variant of external music files.

    Could I see your doomsday.out log from a run where you attempt to change the sound font?

    I think FMOD does have trouble with MIDI music. (In my experience, modern Windows also doesn't seem to have a working software MIDI playback API.) You might have success with a DLS soundfont using FMOD, though. However, FluidSynth is the recommended/default way to play MIDI music.
  • edited Dec 3, 08:51
    skyjake wrote: »
    I'll make a note to fix IDMUS.

    I assume you are talking about MIDI (original MUS) music, and not any variant of external music files.

    Could I see your doomsday.out log from a run where you attempt to change the sound font?

    I think FMOD does have trouble with MIDI music. (In my experience, modern Windows also doesn't seem to have a working software MIDI playback API.) You might have success with a DLS soundfont using FMOD, though. However, FluidSynth is the recommended/default way to play MIDI music.

    Yes, this is with it set to MUS, not external.

    This is all that shows up in Doomsday.out when switching the soundfont.

    To be more specific, this is what happens when loading a soundfont using FluidSynth:

    -The MIDI soundfont is set to "GeneralUser GS". I don't know if this is Doomsday's default soundfont in FluidSynth. When I select my own soundfont, it will show the name of my soundfont (1mgm.sf2, which emulates the old SoundBlaster AWE32/64 soundcard), but when leaving and re-entering the audio configuration console, it goes back to "GeneralUser GS".

    EDIT: The only way I can get music playback out of FluidSynth is if I browse to where Doomsday holds the default .sf2 file (under C:\Users\Administrator\AppData\Local\Deng Team\Doomsday Engine\runtime\cache), where I point it to default.sf2. Even when I point to my own .sf2 file from here, it will still use the .sf2 file in this location.

    EDIT 2: The same thing happens with FMOD. I pulled out the gm.dls file (the default soundfont for Windows), put it into a more common folder that I used, and manually pointed Doomsday to it (to see if FMOD would play properly), but it just doesn't appear to save whatever custom soundfont I load in. Whenever I come back in it's set back to "GeneralUser GS".

    Hope this helps.
    Map: Hangar (Uri: Maps:E1M1, warp: 1)
     - Author: id Software
    
    [BindContext] Impossible selection
    [AudioSystem] Reinitializing all audio interfaces...
               [ > AudioDriver] FMOD by Firelight Technologies Pty Ltd
                                FMOD driver 0: "Speakers (Realtek High Definition Audio) (Stereo)" Rate:
    48000Hz Mode:Stereo Channels:2
    [AudioSystem] Initializing 16 sound effect channels
                  Current soundfont set to: "C:\Users\Administrator\AppData\Local\Deng Team\Doomsday
    Engine\runtime\cache\default.sf2"
                  Audio configuration:
      CD:      Disabled
      Music:   FluidSynth/Ext (MIDI only)
      Music 2: FMOD/Ext
      SFX:     FMOD
    
  • For a quick update, I tested out the build from today. The IDMUS cheat works again, but it doesn't print the "Music Change" message up top.

    As for the soundfonts issue, the only way I can change the soundfont is to drop the soundfont into the AppData\Local\Deng Team\cache folder, and rename it to "default.sf2", which I imagine would be overwritten the next time a build is installed. Would you be able to look into this as well?
  • edited Dec 7, 09:12
    @skyjake

    I can confirm that in the current Doomsday builds the soundfont cannot be changed, despite the audio interface indicating that the user has picked a different soundfont. Upon closing and reopening the audio menu the previously selected soundfont is shown again.
  • I will fix the sound font selection, I can now reproduce the issue myself too...
  • To follow up on that message issue I mentioned with IDMUS, it looks like it's across all of Doomsday. I'm not getting any messages for any item pickups, and I confirmed that I have messages on.

    I did run through Map29 of Plutonia 2 and Map20 of Alien Vendetta (two pretty big maps), and they seem to run a lot better on recent builds of Doomsday!
  • The HUD message bug was caused by changes done on December 4th. Should be fixed now for future builds.
  • edited Dec 9, 14:58
    @skyjake

    I have just installed build 2897. For the audio setup I had to re-browse my external soundfont due to reorganization of my folder structure.

    Of course, due to my folder restructuring Doomsday could not find my soundfont, I hadn't reconfigured it yet as I was waiting for the release of Doomsday build 2897. So currently the MIDI music output was broken, only distorted bits of drums/percussion could be heard.

    For Doom and Heretic updating the soundfont setting went smoothly, in Hexen though I noticed the following:
    • Browsing for an external soundfont the music playback is stopped (paused)
    • Selecting a soundfont the music playback restarts (continues)
    • After I had selected a soundfont, Hexen continued to play the title music using the old, now obsolete setting (I hear broken MIDI sound output as described above). Only after playback of the title music has ended and restarts from the beginning, the new soundfont setting gets used.

    I noticed this only in Hexen probably due to the duration of the title music, which is lasting longer than the Doom and Heretic title music.

    I suggest to adjust the MIDI music setup logic as follows:
    • Stop music output when browsing for a soundfont
    • If browsing dialog is closed with 'OK', re-initialize MIDI output honoring new settings, start playback from beginning of title music
    • If browsing dialog is closed with 'Cancel', no re-initializing required, re-start MIDI playback
  • edited Dec 11, 12:03
    @skyjake

    You probably missed my previous post from December, 9th (see above)?

    Congrats on the release of stable build 2900. :) It was quite a long road from build 2464.
  • Thanks! :) Still working on the final release notes and announcement...

    I suggest you submit this MIDI setup issue as a User Experience bug in the tracker so it will be addressed in a future patch release.
  • Alright, I just raised a bug report.
Sign In or Register to comment.