Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

error when load pk3 file

edited 2016 Jan 12 in Heretic
Hi all,
thanks for your Amazing work!!!...Doomsday is one of my favourite project; revival old games like doom, heretic and hexen is very important for a gamer's culture. However when I start to play with heretic using the "Heretic Resource Pack (jHRP) 2010.09.28+psy" downloaded from doomsday's site, I get an error and the game start without it. The error is this:

says a message

"PK3 info error
There was an error in the metadata entry of the addon jhrp+psy-20100928-pk3, in the file C:\program files\x86\doomsday\snowberry\addons\jhrp+psy-20100928-pk3.

Please help me I really want to enjoy that game with high texture.


  • Thanks! :)

    Perhaps the download was damaged somehow? If you check its size, what does it say? The correct file size of "jhrp+psy-20100928.pk3" is 74371257 bytes.
  • Hi skyjake, it's a honour to meet you.
    Yes the file size is smaller then the size you say (my file is about 64 MB), can you give me a working link? Or re-up in your site?...I really wanto to play in high texture ;-)
    Thanks for all you have done!
  • The file on the server seems ok... Sometimes it helps to try downloading with a different web browser?
  • Ok I try to download it with chrome and microsoft edge (under win 10), chrome and internet explorer (under windows 7) but nothing happened....always i get the same error; I use 2 different computer and internet but the end is the same. The file is 72.629 KB and I think is not damage because if I change ".pk3" extension to "rar" or "zip" i can open it with winrar or winzip without any error, but when i start doomsday I can't play with this pack. Always metadata entry error.
  • well that was a weird experience but thats fire fox for you. it first opened the file as a text document so i had to right click and save it. also for the files you get can you extract stuff from them? if not they they are not fully downloaded as win rar can open rar files even tho they are damaged. same goes for zip files. i think your web browser is closing the download way too early.
  • Hi Gordon,
    I have just tried with firefox under win 7 and nothing is changed; get the same error. Yes if I change the extension of the file from "pk3" to "zip" i can open it with winrar and it is fully extraible to any directory without any decompress error so I think the file is complete.
    Any other solution? :-/
  • I tried modifying the server config so it recognizes PK3 files as downloadable binary data (application/octet-stream). Perhaps this will help?
  • I noticed another thing in the server configuration that might have been confusing the browser: compression was enabled for all served files, so it wasn't telling the browser how large the downloaded file is. I've now disabled that.

    (Weirdly, when downloading with Internet Explorer, it forcibly changes the file extension to ".zip".)
  • Download it again and again but always same error. I think is not a server issue because hexen work fine with all the just heretic don't work. You have tried to download it and start doomsday with it? You got the same error or all work fine?
  • I have solved find another texture pack on web; after small research i have found this ...

    But i don't know if this is bettere o worst then the pk3 in your file archive...I hope to get work yours.
    If to post this link is out of rules delete this last reply.
  • You have tried to download it and start doomsday with it? You got the same error or all work fine?
    I tried downloading a fresh copy of the PK3 from and it works great for me.

    Have you tried clearing your browser's cache?
  • Yes, Trying everythings but none have worked. Did you check the link in my last post; is better or no than the file pk3 in your archive? Anyway the problem still remain :((
  • i know this pack. wile i do not know how up to date it is. it dose have some stuff the one on the addons page dose not.
  • I get the same metadata error when trying to start snowberry using Dday 1.15.5 with that pk3 from the addons page. I also use windows 10 64bit. after closing the error, snowberry opens weirdly and I can't even select pk3s to use. I have to remove that pk3 from my addon folder just to get snowberry to open properly. Download was with chrome. Will try to download with edge and see if it works.
  • Hi Postfatal,
    yes is exactly the same thing happen to me...I try many browser but at the end nothing change, the problem remain. Try the link that I post some post before and tell me if it works: I try that pack on win 7 and works but on windows 10 64bit doesn't work....give me your feedback.
    For the pack in add-on's section of this site I tried it on windows 7 x64 but got same error.
    I hope we find a solution soon.
  • I double-checked the file in Snowberry and it does have bad metadata in its "Info" file. The package itself is fine and contains no errors, and can be loaded in Doomsday via command line options. It's just the frontend that doesn't accept the syntax errors in the "Info".

    I've uploaded a corrected version to
  • Great work Skyjake, well done!!!! =D> =D> =D> =D>
    Now add-on file work fine.
    last question off-topic...this is the last compilation pack of textures, weapon, skin, ecc... about heretic?...or there is some better?
    Anyway thanks a lot for your help! =D> =D>
  • this is the last compilation pack of textures, weapon, skin, ecc... about heretic?...or there is some better?
    As far as I'm aware, this is the latest "complete" collection of resources. There might be some individual assets that are newer.

    DavidInvenio was working on a cleanup to this package, though. There were a few threads posted on Addons for Heretic about that.
Sign In or Register to comment.