Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

NPOT Issue

edited 2008 Jul 5 in Developers
<i>This post was originally made by <b>skyjake</b> on the dengDevs blog. It was posted under the categories: Beta 6, Engine.</i>

It appears that the support for non-power-of-two textures isn't working for me. I've got the <tt>ARB_texture_non_power_of_two</tt> extension, but when enabled (which is the default) the NPOT textures are scrambled. I haven't investigated yet whether this is a problem in our code or in my GL drivers.


Here's some screenshots.
[gallery]

Comments

  • I think it could be an issue with your GL drivers as NPOT textures seem to work fine for me with my 8800 GTX under Vista64.

    With NPOT textures we arn't having to do any resizing thus the menu and other GUIs look far crisper (naturally). At present though I've only enabled them for non-mipmapped textures as I'm sure we have existing code making assumptions that will need be changed.
Sign In or Register to comment.