Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Universal Build #2

edited 2008 Jul 28 in Developers
<i>This post was originally made by <b>skyjake</b> on the dengDevs blog. It was posted under the categories: Beta 5, Mac OS X, Releases, Version 1.9.</i>

I've just uploaded a revised universal build of 1.9.0-beta5.1 for the Mac. This time I tried to make sure that it runs both on Tiger and Leopard and isn't linked to any shared libraries that may not be present in a default installation of the OS.

It works at least for me both in my old PowerBook G4 running Tiger and a Mac Mini with Leopard.

Download the <a href="http://sourceforge.net/project/showfiles.php?group_id=74815&package_id=129649">updated release</a> and let us know if it works better for you.

Comments

  • <i>This comment was posted by dengDevs user <b>tm</b>.</i>

    Crashes on a fresh install on OSX 10.4.11, Macbook Pro 2.16ghz with 3gb RAM. Missing libpng.3.dyl (no /usr/X11 hierarchy at all in fact).

    Host Name: Cerberus
    Date/Time: 2008-05-08 18:00:50.679 -0400
    OS Version: 10.4.11 (Build 8S2167)
    Report Version: 4

    Command: Doomsday
    Path: ../Doomsday.app/Contents/MacOS/Doomsday
    Parent: Doomsday Engine [4340]

    Version: ??? (???)

    PID: 4346
    Thread: Unknown

    Link (dyld) error:

    Library not loaded: /usr/X11/lib/libpng.3.dylib
    Referenced from: /Applications/Doomsday Engine.app/Contents/Resources/../Doomsday.app/Contents/MacOS/Doomsday
    Reason: image not found
  • Please double-check that you're running the universal2 version. This build should not be dynamically linked to anything under /usr/X11. In fact, I can run it just fine on Tiger without /usr/X11 being present.

    You can check it in Finder with Get Info on Doomsday Engine.app. The version field should say "1.9.0-beta5.1-universal2-macosx".
  • <i>This comment was posted by dengDevs user <b>tm</b>.</i>

    Thanks - I was running version 1. universal2 works great!

    - TM
  • <i>This comment was posted by dengDevs user <b>tm</b>.</i>

    I re-played Ultimate Doom and that was a lot of fun, but I'm having a lot of trouble with Doom2 (using the WADs from my original CDs, which I luckily still have) and savefile corruption. At some point, either a save file itself, or one or more of the save "slots" causes a crash when I try to either load or save a game in that slot. I'm not sure which it is. No error message, no crash report, the game just immediately quits. Some saves/slots will work, others will always crash.

    Same machine as originally reported in this thread.

    Any suggestions?

    - TM
Sign In or Register to comment.