Game map not working [SOLVED: Linux; recompiled]

edited Mar 30, 12:34 in Technical Support
Hi all,
I have a problem.

I am running doomsday-2.3.1-1.x86_64.rpm on a linux Mageia 8
kernel 5.10.25
nvidia driver 460.67 on gpu GEFORCE GT 730
x11 server xorg 1.20.10

The interface work well, but when start to game the map is distorted, I only see corridors that rest with messy coatings.
In Doom the player is always in god mode, in Heretic is chrooted in first corridor.
This for all games Doom, Heretic, etc.
Pressing TAB in Doom , I see the map with random lines that form a triangle that widens.
Do you have any tips to solve this problem that makes it impossible for me to play this game.
On my previous mageia 7 with doomsday-2.1.1-1.x86_64.rpm everything worked fine.
Thanks for your help

Comments

  • CAn you run this command in the terminal?
    lshw -c video | grep driver
    
    What driver are you using?
  • Possibly this bug:
    https://tracker.dengine.net/issues/2376

    Build doomsday from source as a workaround.
  • Thanks KuriKai,
    This is the output and the driver:

    [c_mani_m8@Mother ~]$ sudo lshw -c video | grep driver
    configuration: driver=nvidia latency=0

    [c_mani_m8@Mother ~]$ sudo nvidia-smi
    Sun Mar 28 10:54:06 2021
    +
    +
    | NVIDIA-SMI 460.67 Driver Version: 460.67 CUDA Version: 11.2 |
    |
    +
    +
    +
    | GPU Name Persistence-M| Bus-Id Disp.A | Volatile Uncorr. ECC |
    | Fan Temp Perf Pwr:Usage/Cap| Memory-Usage | GPU-Util Compute M. |
    | | | MIG M. |
    |===============================+======================+======================|
    | 0 GeForce GT 730 Off | 00000000:08:00.0 N/A | N/A |
    | N/A 33C P0 N/A / N/A | 242MiB / 1994MiB | N/A Default |
    | | | N/A |
    +
    +
    +
    +

    +
    +
    | Processes: |
    | GPU GI CI PID Type Process name GPU Memory |
    | ID ID Usage |
    |=============================================================================|
    | No running processes found |
    +
    +
    [c_mani_m8@Mother ~]$
  • Thanks thesourcehim,
    If not there is another solution I will prepare to compile it from source.
  • cool so that rules out the nouveau driver caussing an issue
  • edited Mar 29, 20:48
    Good news, I have compilated doomsday-2.3.1 and all work like a charme!!! :D:) .
    The problem is resolved!!
  • thank you all
Sign In or Register to comment.