Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

what opengl extension i need for doomsday engine?

edited Mar 13, 06:49 in General
hi, i gotten a new laptop. its asus. its windows 7. its one of the new ones and it suppose to came with a blue ray player. but, it didn't.

so im working on it.

now i got doomsday back on. now it gives me this error: "Application terminated Due to exception(in GLInfo::init)Failed to intialize Opengl"

what extension am i missing for Opengl?

Comments

  • Usually updating video drivers is enough. You need updated drivers from the manufacturer of its video card.

    The manufacturer of the laptop would usually provide you with older drivers.

    And then there is the driver provided by Microsoft's "Windows Update". Those are usually stripped of OpenGL, because that's a way for Microsoft to push their DirectX.
  • Makaki wrote: »
    Usually updating video drivers is enough. You need updated drivers from the manufacturer of its video card.

    The manufacturer of the laptop would usually provide you with older drivers.

    And then there is the driver provided by Microsoft's "Windows Update". Those are usually stripped of OpenGL, because that's a way for Microsoft to push their DirectX.

    really?

    thats good to know. so sounds like mine still has uit. just needs updating of opengl drivers.

    im assuming on microsoft website there is a update for that one?
  • You don't want the microsoft variant of the driver, because it's a simplified driver without OpenGL support. You want the full feature driver from the manufacturer of the video card. (or laptop manufacturer as 2nd option)
  • Makaki wrote: »
    You don't want the microsoft variant of the driver, because it's a simplified driver without OpenGL support. You want the full feature driver from the manufacturer of the video card. (or laptop manufacturer as 2nd option)

    can you give me the link? im using asus windows 7 laptop. its the one with the blueray in it. its the model number n53sv one.
  • Accoriding to the specs your laptop has:
    NVIDIA® GeForce® GT 540M with 1GB DDR3 VRAM

    So you would go to nvidia.com click where it says drivers and search that:

    Assuming your windows is 64-bit, the result should be:
    https://www.nvidia.com/Download/driverResults.aspx/132844/en-us
    OR
    https://www.geforce.com/drivers/results/132844
  • Makaki wrote: »
    Accoriding to the specs your laptop has:
    NVIDIA® GeForce® GT 540M with 1GB DDR3 VRAM

    So you would go to nvidia.com click where it says drivers and search that:

    Assuming your windows is 64-bit, the result should be:
    https://www.nvidia.com/Download/driverResults.aspx/132844/en-us
    OR
    https://www.geforce.com/drivers/results/132844

    cool, mine is defiantly 64 bit.
  • Makaki wrote: »
    Accoriding to the specs your laptop has:
    NVIDIA® GeForce® GT 540M with 1GB DDR3 VRAM

    So you would go to nvidia.com click where it says drivers and search that:

    Assuming your windows is 64-bit, the result should be:
    https://www.nvidia.com/Download/driverResults.aspx/132844/en-us
    OR
    https://www.geforce.com/drivers/results/132844

    i tried them and it didnt work. it still gives me the same message. im assuming its compatibility?
  • Makaki wrote: »
    Accoriding to the specs your laptop has:
    NVIDIA® GeForce® GT 540M with 1GB DDR3 VRAM

    So you would go to nvidia.com click where it says drivers and search that:

    Assuming your windows is 64-bit, the result should be:
    https://www.nvidia.com/Download/driverResults.aspx/132844/en-us
    OR
    https://www.geforce.com/drivers/results/132844

    to let you know. i posted a bug for doomsday on bug tracker. i was able to install the drivers. but, i just couldnt load doomsday. i load both geforce experience and the driver you found.

    so i sent them a bug report.
  • Make sure you actually start Doomsday using NVIDIA graphics and not integrated one. Open NVIDIA control panel, go to 3D settings, switch to applications tab and add doomsday executable to the list. Then set GPU to NVIDIA for Doomsday,
  • edited Mar 16, 07:54
    Can you also make sure that your new NVIDIA drivers are working in some other OpenGL game or app?

    According to the driver release notes, they support OpenGL 4.6 which is more than enough for Doomsday. The minimum required version is currently OpenGL 3.3.
  • Make sure you actually start Doomsday using NVIDIA graphics and not integrated one. Open NVIDIA control panel, go to 3D settings, switch to applications tab and add doomsday executable to the list. Then set GPU to NVIDIA for Doomsday,

    thanks, it works.
Sign In or Register to comment.