Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Mouse? (should I be seeing my mouse on the main screen?)

I just downloaded the 2.2.1 zip on my workstation, which is Win7.64 (16gb ram and plenty of everything). I copied it to where I want it and ran Doomsday.exe. It runs ok but I immediately notice that I don't see my mouse cursor. I have 2 monitors going, and the mouse works fine when I move over to the secondary. But the primary, where I'm running DE, shows no mouse cursor. I can show the taskbar or startmenu and the mouse is there, I can switch to other apps and it works there as well. There's nothing fancy in my setup, just a Logitech Perf/MX. I'm sure there's something I'm doing wrong but I looked thru the User Guide and Getting Started, the FAQ and did some searching of the forums.

Anyone got any tips?

PS: I've been out of the DEng world for a number of years while I worked myself to death LOL but I've decided to retire after 35yrs writing code and I've been a huge fan of yours, SkyJake, and your work. And I'm really excited about getting back into it and enjoying my computers (and my life!) again. I'm VERY HAPPY to see that you've kept your project going, it speaks volumes about anyone who stays with a project as long as you have! So cheers mate, and I look forward to talking with you more in coming days!

Peace
/D

Comments

  • Update: I prefer not using installers and instead using portable dists - but I really want to see DE again so I downloaded and ran the 64bit .msi and the mouse seems to work now! Which leads to the question: Exactly what does the installer do that running the portable dist doesn't? I am a bit comfortable with doing configuration manually lol - and I'd really like to use the portable from this point on if possible. But obviously I'll need the mouse :-)
    Thanks in advance!
  • what does the installer do that running the portable dist doesn't?
    Both the MSI and ZIP installers should have the exact same files, and neither puts anything in the system folders.

    Did you unzip the zip install to a new empty folder? If not, some older files/libraries may be causing trouble.

    There's always the chance of some random Windows weirdness, did you try a reboot? :smile:

    But I'm nowadays using Windows 10 only so it could be some incompatibility with the older OS.
    I'm really excited about getting back into it and enjoying my computers (and my life!) again.
    Congrats! :smiley:
  • Greetings
    I also just downloaded and installed Doomsdat 2.2.1. and the mouse does not appear in the UI screen. My computer is running Windows 10. I just bought this laptop two weeks ago so the problem can not be a compatibility problem cause by using an older OS Unfortunately I don't recall which installer I used (doomsday_2.2.1_x64,zip or doomsday_2.2.1_x86.zip) as I deleted it once I installed the doomsday engine.

    I have found two work arounds to get the mouse cursor to appear in Windows 10.
    1) Press F4 then ESC and the cursor will appear. This first fix only works until you select something then the mouse will disappear so you have to press F4 and esc again.
    2) This second fix will keep the mouse visible in the UI. First open a window, I open the File Explorer. Next double click on DE to start it. Before DE has completely initializing click once inside the File explore window so it is the active window. DE will start behind it. Once DE has started click in the UI to make it the active window and use the mouse, it will not disappear.

    However I am going to try a reinstall as suggested.
    Regards
  • This sounds like some newly introduced issue with Qt. I’ll have to take a closer look...
  • Greetings,
    Just an update. I just installed doomsday_2.2.2_x64.msi and the cursor is working normally.

    Regards
  • Hmm, that means it was likely not related to Doomsday after all. I haven't changed anything that affects the mouse.
  • Apologies for resurrecting this old post... but I really want to get DE working and I'm out of ideas. I recently did a clean install of Win7.64 and all details of my original post are the same. I have installed v2.2.2 and tried the workarounds and suggestions but no luck. The DE .out log file shows nothing about the mouse. I noticed that the issue is not that the mouse doesn't exist in DE - if I move around blindly and click sometimes it hits on something. And while DE is running the mouse works perfectly elsewhere. Yes I have made sure that the mouse is configured to use the standard default pointers and there is nothing out of the ordinary about my setup. I use this same setup to run MAME, Dosbox, VirtualBox with Win10 and various Linux guests - and all 100% perfect. I have tried several mice but unfortunately I only use Logitech so they are all the same brand and use the same unified driver and are all usb wireless. I am able to run games fine, at least the one I've tried so far, Heretic, and the mouse works fine in the game for looking around. It's the DE ui that has the issue, that much is certain at this point.

    So I'll ask a couple questions, after looking through the online docs I wasn't able to find the answers myself. First, is it required for DE to run only full-screen? My primary display is 36" and I don't really need Heretic that big. I am running dual display, as it's a laptop. But this is set to primary.
    Second question is should I have DE do more logging? And how/what should I set?

    One other detail I just remembered is that if I put any other window in front of DE, when the pointer appears I can move it right over the DE window and click on whatever I want in DE and it works. Which I expect given that I had already found it was just a visibility issue.

    Thanks in advance for any suggestions. I do not use the mouse in any games, however it's pretty painful trying to configure stuff in DE by keyboard. Right now I'm trying to figure out why the (ancient) Heretic resource pack isn't working properly. I thought I had configured it properly but again hard to tell.
  • First, is it required for DE to run only full-screen?
    No, you can run in windowed mode as well. Normally you'd active this via the GUI, but given your predicament I suggest launching doomsday.exe with the "-window" option instead. Alternatively you can try pressing F11 when Doomsday is running to toggle fullscreen mode off and on.
    Second question is should I have DE do more logging? And how/what should I set?
    I doubt extra logging would reveal anything that would be relevant to the mouse cursor not being visible...

    If all else fails, I can pretty easily add an option that draws the mouse cursor via in-game graphics so it's forced to be visible even if the system cursor isn't. (The code already exists for the Oculus VR stuff.)
  • Hey mate thanks for the speedy reply! And bigger thankses for the F11 info because once it's in a window the mouse pointer is visible and so far seems to be working perfectly! W00H00YAYY!!! Geez it seems like a simple thing....now ;-) I have to refamiliarize myself with DE.
    And thanks for the offer of further assistance, there's nobody on the planet who supports their users better than you. Much appreciated mate.

    (I can't help but be curious about what the issue might be though, but you can close this issue far as I'm concerned!)
Sign In or Register to comment.