Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

2.3 unstable linux: garbled music

In latest unstable builds music playback gone bad (FluidSynth), I hear a lot of static noise during playback. Tried to change between different numbers of channels, doesn't help. Other plugins can't play music at all.


  • edited 2019 Dec 27
    Default soundfont or something else?

    DEB, RPM, or Flatpak?

    The Flatpak build only comes with SDL_mixer + FluidSynth, even though the UI has the "FMOD" option. (That's a bug.) In any case, you can see the currently used audio backend config in Doomsday's About box > Audio button. It's also printed to doomsday.out on launch.

    I've heard other reports of garbled music on Linux, but of course on my system everything works great so I have no way to investigate the issue.

    EDIT: Actually, I just noticed that in the Flatpak build one can't adjust music volume at all. SFX works.
  • It's flatpak. I compared to RPM version and noticed the following differences:
    1. In RPM music plays fine
    2. In flatpak I can not select audio output (the list is empty), while in RPM I can.

    Maybe flatpak version is missing some dependencies in the manifest? Or some permissions?
    Also one of the dependencies can not be installed from flatpak (org.freedesktop.Platform.openh264) due to the known bug in the package. Could it be related to the problem?
  • I tried selecting different sound font, but it doesn't work at all, I get error message 'failed to load music, can not open /etc/timidity/freepats.cfg). Only default sound font works.
  • In the latest unstable build, does adjusting music volume affect the static noise at all? I've made a change in how volume is applied in FluidSynth.
  • Build 3282, the volume is definitely applied on change, static noise volume changes too, but noise is present. When run with -v I noticed another error message about fluidsynth can not set high thread priority. I'm in audio group.
    Full output with -v:
Sign In or Register to comment.