Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Joystick "Saitec Cyborg evo force" does not work

edited Nov 30, 06:38 in Technical Support
hello,
i use Windows 10 64bit and a Joystick "Saitec Cyborg evo force"
The doomsday engine is up to date.
greetings

Comments

  • edited Nov 30, 06:44
    Some of this may help you:
    1. Load up a game.
    2. Go to taskbar > ⚙️ > Input.
    3. Make sure "Game Controllers Enabled" is toggled on.
    4. Select "Generic" from the Game Controllers Preset selection and press Apply.
    5. Go to the game's Options > Controls menu.
    6. Check that there are bindings starting with the ID "joy-".
    7. Try to set a binding for instance for "Forward" control using the joystick.
  • Hello skyjake,

    Taskbar:
    Unfortunately, I can not find an entry for a game controller.
    There I find only:
    Video
    Audio
    Network
    Data files
    User interface
    Updater
  • edited Nov 30, 10:42
    You have to be in a game for some options to appear?
  • Hello,

    When I go into the game, I can in "Controls"
    Change settings. But the joystick is not recognized.
  • hallo,
    hello,
    Gibt es da eine Datei zum konfigurieren ?
    (zum Aktivieren des Joysticks ?)

    Is there a file to configure?
    (to activate the joystick?)

    Volker
  • All the settings are under the "configs" directory inside the Doomsday runtime folder: https://manual.dengine.net/guide/2.2/readme_windows#files

    Look for the cvars that begin with "input-joy-".

    However, the same settings are available in the GUI (as mentioned in my first reply).

    Could you attach here your doomsday.out log file? (Add a ".txt" suffix to make the forums happy.)
  • edited Dec 3, 17:01
    Attached the "Doomsday.out.txt" file.
    Not allowed here...
  • edited Dec 3, 17:01
    erased.
  • Attached the "Doomsday.out.txt" file.
  • I'm not seeing any logs?

    You could try https://pastebin.com instead.
  • in the file "bindings.cfg" (C:\Users\Volker\AppData\Local\Deng Team\Doomsday Engine\runtime\configs\doom\player) stands:

    "Use autoexec.cfg
    for your own startup commands."


    where can i find the file ?
  • edited Dec 5, 08:31
    It doesn't exist by default, you need to create it yourself in a text editor.

    The path would be: "C:\Users\Volker\AppData\Local\Deng Team\Doomsday Engine\runtime\autoexec.cfg"
  • hello skyjake,
    The file "autoexec.cfg" is not available on my computer.

    i cannot fint it anywhere.
  • hello skyjake,

    Problem solved.
    It was very simple:
    Press Shift ESC while a game is loading.
    I did not know that.
    Now I just have to disable the "Side-Step".
    Rotation of the character by joystick.

    Volker

  • Glad to hear it!
Sign In or Register to comment.