Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Doomsday for Mac - mouse starts spinning in any game I load...

Hello. I'm experiencing a weird problem with the Mac version of the Doomsday engine - specifically version 1.9.9 - I prefer this version to the newest one because it's easier and more straight forward, and also has the resolution and display/graphics settings in the main menu, among other useful settings (If the newest version has this as well then I haven't been able to find it!) Also, I'm using this on a Macbook Pro running mojave. if that is a factor in this problem.. So whenever I load a game - any game it seems - the mouse starts flipping up or down and spinning out of control. I don't have a mouse of any kind connected, just using the trackpad. I've disabled bluetooth thinking it might be my ps4 controller causing a problem but no change at all. It also does this in the control panel within the options.

What is the issue and how do I fix it? I never had this problem on my previous macbook from a few years ago. I don't have this problem on the newest version of doomsday but I definitely prefer 1.9.9 for the options and simplicity - oh and the newest version won't recognize my heretic.wad file - I've tried a few different ones to see if it was a problem with the wad itself but no luck - doomsday 2.1.1 says it's missing the data files and I can't see any options to try to fix it other than the directory option.) So I would much rather prefer to stick with 1.9.9 if I can. I have no idea what could possibly cause this!? Oh and doesn't start until I actually touch the trackpad. It will just sit there but once my finger even grazes the trackpad it goes crazy, even if I stop touching it!

I would imagine that this problem would have had to come up before in the long history of doomsday, or at least I HOPE it has.. Maybe it's a mac thing? This is the only app or game I've ever encountered this with.. ANY help with this would be VERY appreciated, thank you.


  • I've noticed this issue sometimes happening on Mojave. It probably has something to do with the newly added Accessibility security settings — they are preventing Doomsday from reading and updating the cursor position as it expects.

    One thing you could try is going to System Preferences > Security & Privacy > Privacy tab > Accessibility, and enabling Doomsday to have permission to control the computer.

    If you don't use the trackpad as a game control, you could try disabling mouse input. I don't recall off the top of my head how that was done in 1.9.9 (apart from the "-nomouse" command line option), but in the newer versions there are toggles in the taskbar > ⚙️ > Input settings.

    When it comes to your Heretic.wad, you may have a version of the WAD that is unsupported or just unknown to Doomsday. In 2.1, you can now configure a custom game profile to launch with any IWAD. This is done by creating a game profile in the game library and clicking on the "Data File: Default game data" button to select which IWAD to use.
  • I have tried disabling the mouse but then the problem there is of course I can't use the mouse! Which I definitely prefer with these games. I was able to disable the mouse in the main doomsday options and there's also an option within the games. the in-game method stopped the spinning but the front-end option didn't change anything in-game... But right now I've just re-installed it and was testing everything with just using the trackpad but I do want to eventually use a proper mouse when I go to play games. I haven't tried to setup my ps4 controller with this, does doomsday support bluetooth gamepads?

    Also, I tried the security & privacy thing u mentioned and it appears that doomsday was already in the list of apps that can control my computer - both under accessibility and 'full disk access.'

    Is there no other fix for this issue? I can't possibly be the first and only unlucky user who's had this problem!?

  • I ran into this too on Mojave, and Accessibility was the issue. During the install, Mojave will prompt you to add Doomsday Engine. Your best bet may be to:
    • Remove Doomsday Engine's entries you added to Accessibility and Full Disk Access (Click each Doomsday Engine entry, then click the minus ( - ) button).
    • Remove the app and all supporting files (see the readme on the installation disk image for locations of all files)
    • Re-install and add DE to the Accessibility settings when prompted. Add it manually after the install if you don't get prompted.

    Give that a shot; hopefully that will get you your mouse control back.
  • Hi all, firstly, thanks for these replies, it really helped me and my friend. Secondly, I just wanted to report that once my friend changed security and privacy settings to include Doomsday, it solved the jumpy mouse problem for us. Didn't need to re-install.
    We weren't initially sure if we'd have to re-install or not so I'm just posting this message for future reference for users of Doomsday on Mojave.
    Hope OP sorted their problem out.
Sign In or Register to comment.