Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Doomsday 2.2.0 Latest build 2983, skybox+crosshair problem

So I downloaded the new Doomsday and started up Doom, and I came across an extremely strange problem. The moment I turn toward where I can see "outside", the whole level disappears and all that is visible is the skybox and a crosshair. The moment I turn back to look "inside" the level returns. This happens in all the Doom games, but not Heretic or Hexen. In the first level of Knee Deep this would for example be turning right toward the courtyard, in Doom2 this is for example turning around in the first level to go toward the chainsaw.

The game shows several warnings, not being able to load a texture in jDoom and jHeretic addons; not loading the addons has no effect on the problem. Then there's a warning about a turningskull not being defined in .cfg file of Heretic, but since Heretic doesn't have this problem I doubt it produces problems in Doom.

It temporarily resolved itself in Doom 2, instead of just going skybox-crosshair, there was a momentary blip of skybox-crosshair which then disappeared; allowing me to get to the chainsaw and start playing the level. However, by the time I was in the the room with the exit-door, the problem once again returned.

There was a yellow alert triangle warning, that said something like, 0<= something map color something <=1, however, that error no longer shows up, so I can't tell what it was exactly. I attached the doomsday.out file.

Anyone have a clue what this is/solve the problem? Or is it straight up an issue with the build that needs resolving?

Comments

  • Addendum Build 2990 does not solve the problem.
  • For what it is worth, I played Doom 1 and 2 first episodes with 38 add-ons and all seemed normal except the HUD Sprit for the Chain Gun (only the rotating barrels were visible, the actual gun holding the rotating barrels was almost completely absent) and the BFG9000 HUD sprit was the pixelated blurry original for some reason.

    SkyJake said that the coming changes in the renderer would be more problematic than in the past perhaps this is what he meant?

    I suspect Skyjake will want to know of such things but for me it is just minor things but it could help Skyjake (of course for some with their Doomsday configuration it may not be so minor).

    With major changes in the renderer ongoing I doubt it would be worth trying to address my observed minor changes since the render will be in a state of flux but others like you may have more serious problems.
  • Can you confirm that the rendering glitch occurs also when no mods are loaded?
  • The chain gun is properly rendered (not in HD of course) if I drop the jDoom Resource Pack (jdrp) file.box.jdrp.

    The Specific pk3 is jdrp-w-chaingun.1.01.pk3 – 4/4/07.

    These minor cosmetic alterations are not a problem for me.
  • The glitch occurs only when hi-res skyboxes are loaded; without new skyboxes the game runs fine.
  • 3DMaster wrote: »
    The glitch occurs only when hi-res skyboxes are loaded; without new skyboxes the game runs fine.

    Could be a regression in the skybox renderer, then. I'll try to reproduce the glitch on my end.
  • edited Mar 18, 17:09
    The new build (2996) solved not only the skybox problem, but also removed the white edges from the neural upscale sprites. So, great!
  • John wrote: »
    The chain gun is properly rendered (not in HD of course) if I drop the jDoom Resource Pack (jdrp) file.box.jdrp.

    The Specific pk3 is jdrp-w-chaingun.1.01.pk3 – 4/4/07.

    These minor cosmetic alterations are not a problem for me.

    Update:
    I updated my version of DHMP to the 2018 version and this solved the chain-gun rendering problem.
Sign In or Register to comment.