Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Failed to load "dgl.draw"?

Okay, so I had installed doomsday on my laptop running Windows 7. I had been able to run 2.0.3 awhile back before with little trouble (both on MacOS, and Windows 8.1), in fact this was the first source port I had when I had played doom for my very first time. I decided to install the latest version, 2.1 (stable build 2900), and was pleasantly surprised by the new items on the UI, and also surprised that it auto detected my steam purchased doom wads. However, when I attempted to run the wad, the usual cog loading wheel popped up and when it got full doomsday crashed and an error message appeared saying:
"Application terminated due to exception:
(in GLShaderBank::data) Failed to load "dgl.draw"

I'm completely baffled by the problem and don't even know where to start, I've downloaded and reinstalled several times, even installed the 32 bit version instead, and nothing has worked. I downloaded the .zip instead of the msi and still no luck. Can someone please help me at least get a start as to what the error means? And why doomsday isn't working for me?

Comments

  • edited Jan 17, 10:42
    dgl.draw belongs to the Legacy DGL Drawing routines and is included in this file:
    Doomsday\Data\net.dengine.client.pack
    
    I suggest to try different Doomsday builds to see whether the problem persists. For example try the previous stable build 2464, or the recent release candidate build 2919.
  • edited Jan 17, 19:30
    I did install the older stable build suggested and while my games were able to properly load now, anytime I beat any level it simply stopped responding in which windows gives me the choice of waiting until it does respond or simply closing the program. And DOOM 2 still does not load up, and an error appears similar to the other one, except it displays:
    (in BusyMode::PerformTask) Task failed: Uncaught exception from busy thread

    The release candidate build I had also tried but it does no different from the 2900 build, and has the same error as before.
  • When did you update your video drivers the last time? For example, if you are on Windows 10 and have recently upgraded to Windows build 1809, chances are that your video driver is not correctly installed anymore. I witness similar issues after every Windows 10 upgrade, usually reinstalling the current graphic drivers (or a recent version if you like) fixes any such issues, at least it did for me so far.

    Btw, if you have a dedicated soundcard, similar issues can apply here, too. These can be fixed using the same way by either reinstalling the current drivers or an updated set, if available.
  • Version 2.1 has a more advanced DGL shader (called "dgl.draw") that requires OpenGL 3.3 Core Profile. A failure to load it strongly suggests that your graphics/OpenGL drivers are incompatible or out of date.
  • I did update my video drivers and that solved the problem. I do have one new problem concerning DOOM 64: Absolution, in which the "(in BusyMode::PerformTask) Task failed: Uncaught exception from busy thread" error pops up when I try to load it. And it didn't detect the absolution iwad before that so i tried downloading another one in which that new problem came up. But, other than that. Everything has been working fine.
  • Also, thank you, for you have been quite helpful.
  • You are welcome, I'm glad to hear that you could solve the issue. Regarding Doom64 Absolution please refer to this post.

    Download link for the WAD mentioned in that post: Doom64.wad
Sign In or Register to comment.