Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Low frame rate in Hexen - doomsday engine 2.1 (stable build 2900)

Hi all,
i'm new here and i find this engine very great because it's allow me to play my old favorite game (like Hexen, Doom, etc.)
in high resolution.
The issue I am experiencing is in Hexen in the large areas: the frame rate is quite low, around 24-30 fps, while in small areas it is normal, around 59-60 fps (as my monitor supports).

Despite having pretty recent hardware, (I5 3570K, MSI Geforce 970 Gtx OC 4 GB, 16 GB ram ddr3, SSD 250 Gb) the frame rate is still low.

The addons i loaded are "Hexen Community Compilation Pack (jXCCP)" V.1.31 and Hexen Texture Pack downloaded from their proper area in this site.

Is it normal that this is so or can we something be done?

P.S.
In the 1.10.3 version of the engine it didn't happen, but unfortunately it's not compatible with windows 10.

Thank you
to everyone.

Comments

  • Compared to 1.10, unfortunately the renderer has been inflicted with some performance bottlenecks.

    Here are some things you can do to see what is triggering the slowdown:
    • If reducing pixel density or window resolution/size increases FPS back to 60, the problem is that the GPU is too slow. (With GTX 970, this shouldn't be the case.) It might help to disable the Bloom effect in this case.
    • When in a large map you notice the slowdown (perhaps looking at a large open area), does the FPS significantly increase if you turn and face a wall so that nothing but the wall is visible? This would indicate the slowdown is caused by the renderer's per-frame geometry processing.
    • Does the slowdown go away if you don't use add-ons? Some maps have tons of objects or light decorations so rendering these might get expensive. Some texture packs may also be too large to comfortably fit in GPU memory. (4 GB should be quite OK, though.)
  • skyjake wrote: »
    Compared to 1.10, unfortunately the renderer has been inflicted with some performance bottlenecks.

    Here are some things you can do to see what is triggering the slowdown:
    • If reducing pixel density or window resolution/size increases FPS back to 60, the problem is that the GPU is too slow. (With GTX 970, this shouldn't be the case.) It might help to disable the Bloom effect in this case.
    • When in a large map you notice the slowdown (perhaps looking at a large open area), does the FPS significantly increase if you turn and face a wall so that nothing but the wall is visible? This would indicate the slowdown is caused by the renderer's per-frame geometry processing.
    • Does the slowdown go away if you don't use add-ons? Some maps have tons of objects or light decorations so rendering these might get expensive. Some texture packs may also be too large to comfortably fit in GPU memory. (4 GB should be quite OK, though.)


    Hi Skyjake thanks for reply.
    It 's just as you say, in the large areas the slowdown occurs when I look at large areas (24-43 fps), when instead I look face a wall, the frame rate increases to 60 fps without slowing down and the wall remains visible.

    Yes, if I do not use add-ons the slowdown goes away and the fluidity is excellent (60 fps, for example in the "Seven portal" map)
    I will try to disable the bloom effect to see if it improves something, then I will tell you.
    For the meanwhile, I thank you again.

Sign In or Register to comment.