Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Build 2879: lump loading issues

edited Nov 20, 12:41 in Technical Support
I was exited to learn that you managed to fix the Demon and Spectre render issue. I'm happy to confirm the issue is successfully fixed, great job!

To test the fix I launched DOOM Ultimate and warped to E1M8, where the player is welcomed by a bunch of demons. The MIDI music does not play, an error is logged (see details below). So I went to load each level of all my installed games to check for any further issues:

1. Ultimate DOOM:
E1M8: no MIDI music playback
Failed to write to "temp/dd-buffered-song0": [Error] (in Wad::cacheLump) Failed on allocation of 0 bytes for cache copy of lump #84
2. Ultimate DOOM (BFG Edition):
E1M8: no MIDI music playback
Failed to write to "temp/dd-buffered-song0": [Error] (in Wad::cacheLump) Failed on allocation of 0 bytes for cache copy of lump #88
Main menu: Cannot display HELP2.
Missing patch 'HELP2'.
Failed to locate lump for "Patches:HELP2"
E4M8: Final intermission is not triggered upon walking into exit (circle), no error message.

3. DOOM 2: Hell on Earth:
no issues

4. Final DOOM: The Plutonia Experiment:
no issues

5. Final DOOM: TNT: Evilution:
Map 09: no MIDI music playback, no error message.

6. DOOM 2: Hell on Earth (BFG Edition):
no issues

7. No Rest for the Living:
Warping to a map outside the episode (map10 and above), Doomsday appears to derive the music lumps from "Doom2 BFG Edition.wad". For Map33 no MIDI music is played.
Music "map33" not defined, cannot start playback
8. Heretic: Shadow of the Serpent Riders:
no issues

9. Hexen:
no issues

10. Hexen: Death Kings of the Dark Citadel:
no issues

Comments

Sign In or Register to comment.