Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Couple of issues with my Heretic project

Hi there,

I made a new episode for Heretic and I wanted to be supported in most doom ports, so I tried Doomsday and here are some issues

1) After finnishing first map it shows only blackscreen, music is playing, but nothing is happening...
When i load the save position and try it agian, it happens again.

It doesn't seem to happening in other maps (which is strange, because it shows the same Heretic Map). The map of the word was edited, but still...

2) Sometimes there are FPS drops when there are too big spaces and too much enemies - there is nothing you I can do to avoid this? I mean, the engine doesn't assume too complex maps and such?

3) Some textures doesn't work and it shows only black color instead. Why?

Thanks for your replies!

M.

Comments

  • edited Oct 14, 09:00
    1) I'm afraid we need more information. Do you mean the intermission background isn't displayed, but the text displays for instance?

    2) Ddays renderer is designed for older computers and doesn't work as well on modern computers. Skyjake is working on a anew renderer of which you can check the progress on in recent news posts (Edit Blog posts, sorry).

    3) The last time I tried it, in wad PNG textures were broken and displayed as black. Either switch them to doom format textures or load them as replacements for doom format textures.
  • edited Oct 13, 11:12
    Vermil:

    1) Well, you finish the map and it shows statistics of kills and items and secrets as usual

    Then it should show the map of the world and your location, however it shows only black screen and you can hear music, but nothing happens.. only ESC is the only key that responds...

    It happend only after map 1.

    2+3) Okay!

    Thanks for your response!
  • The "Now Entering the Dungeons" intermission screen. for Heretic.

    I've noticed this sort of thing with Doom2 for map07, in multiplayer mode its text screen doesn't show, which is fine. Although it only shows black, if you wait for about 30 seconds or so, the map will start. ~ but before then you only see black.
  • Actually it happens only if your choose the pwad as an episode (if your launch Heretic with some pwad, it shows in the list of episodes the regular episodes from Heretic + under them, there is the one contained in pwad...) if you choose this one, it shows the blackscreen

    if you choose the first one, it actually loads the pwad and it works fine

    30 second waiting didn't help on my side :)
  • @Matthias It sounds like you are actually defining a new episode using DED? (or perhaps MAPINFO)? If so, could I have a look at your definition/mapinfo please?
  • sure

    / Everything sucks - 2017 MAPINFO
    // by Matthias
    defaultmap
    nojump
    nocrouch

    episode E1M1
    name "It's real and it kills"

    map E1M1 "The Harbor"
    levelnum 1
    next E1M2
    sky1 SKY1 0
    cluster 1
    music MUS_E1M1
    //The Harbor

    map E1M2 "The Caverns"
    levelnum 2
    next E1M3
    sky1 SKY1 0
    cluster 1
    music MUS_E1M2
    //The Lava Dungeon

    map E1M3 "In Tremor Dei"
    levelnum 3
    next E1M4
    sky1 SKY1 0
    cluster 1
    music MUS_E1M3
    //The Graveyard

    map E1M4 "The City"
    levelnum 4
    next E1M5
    sky1 SKY1 0
    cluster 1
    music MUS_E1M4
    //The City

    map E1M5 "The Winter"
    levelnum 5
    next E1M6
    sky1 SKY1 0
    cluster 1
    music MUS_E1M5

    map E1M6 "The Spaceship"
    levelnum 6
    next E1M7
    secretnext E1M9
    sky1 SKY1 0
    cluster 1
    music MUS_E1M6

    map E1M7 "The Water Maze"
    levelnum 7
    next E1M8
    sky1 SKY1 0
    cluster 1
    music MUS_E1M7

    map E1M8 "Procyon Lotor"
    levelnum 8
    next E2M1
    sky1 SKY1 0
    cluster 1
    music MUS_E1M8

    map E1M9 "House of Blood"
    levelnum 9
    next E1M7
    sky1 SKY1 0
    cluster 1
    music MUS_E1M9
Sign In or Register to comment.