Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

bad_alloc on Mac OS X 10.6.8 with Doomsday Engine 1.14.0

I'm a first time user of Doomsday Engine on Mac. I tried using it on Ultimate Doom
and it came up with the splash screen with the option of using the tutorial or not
and then crashed with the following (relevant) output:

Starting tutorial (not shown before)
S_StartMusic: Starting music 'intro'
Doomsday(477,0x7fff70ef3cc0) malloc: *** mmap(size=18446744069414584320) failed (error code=12)
*** error: can't allocate region
*** set a breakpoint in malloc_error_break to debug
MasterWorker: Received 1 servers from master
Application terminated due to exception:

Unloaded game
Restoring original display mode due to shutdown
Z_Shutdown: Used 1 volumes, total 33554432 bytes.

Notice the "malloc" size being allocated! I doubt any computer system has that much memory!

What is causing this problem, and how do I correct it?


  • Version 1.14 is quite old, so unfortunately it's difficult to say which bug is causing this error... I don't have a Snow Leopard running anywhere so I can't really debug it either.

    Is there any additional information available in the system logs? (E.g.,
  • For what it's worth (it might even be an improper thing to do with version 1.14),
    I tried the exact same thing that failed above on 10.6.8 on 10.11.6 and it failed
    in almost the exact same way. My Mac Pro 2008 machine is running both 10.6.8,
    10.11.6, and Linux. (The Linux is so I can always have a current running OS with
    a browser that websites won't reject as they do occasionally with my 10.6.8 and
    even 10.11.6 OSes, since they are not upgradable anymore thanks to Apple and
    its stated planned obsolescence policy, but that's another story!)

    Since you don't have a Snow Leopard to debug on, and since I do have it, can I do
    anything for you? I'm not sure what you would have in mind, but if I can do it, and
    you want to pursue it, I'm game to give it a go, as long as you spell out what to do
    and don't assume anything on my part as to how to do it/anything.

    Also, I looked through existing logs and anything I could find, but I don't find
    anymore information that could help you.
  • One potential reason for the crash is a compatibility issue with the graphics drivers.

    You could try starting Doomsday with some custom options. I recall 1.14 still has the separate front-end app for configuration; there is a page for Developer options. You could try adding at least "-novsync -nofsaa -window -wh 1024 768".
Sign In or Register to comment.