Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Shift + Alt doesn't work [GNU/Linux]

edited Jan 30, 04:29 in Technical Support
[Update:: Confirmed on OpenSUSE Leap (KDE, MATE, and IceWM), Kubuntu, and Ubuntu on different computers and multiple versions of Doomsday Engine]

Just wanted to see if anyone can quickly test this for me so I can start isolating the potential cause. Holding "Shift" and using "Alt" (no matter if it's bound to fire or strafe) doesn't seems to work. This isn't a problem with any other key bindings (using left mouse and "Ctrl" while holding "Shift" works fine) so I'm trying to narrow it down to my current build. Anyone else have this problem or is it just me?

OS: OpenSUSE Leap 42.3
Doomsday Engine Frontent: 1.6
Doomsday: 1.14.5
Keyboard: Razor Black Widow (tenkeyless)
All add-ons disabled

Comments

  • Is "alt" set to move window in your desktop Environment?
  • Thanks for the reply KuriKai! No, I'm running stock KDE. I've run Quake (Darkplaces) and Quake 2 (yamagi-quake2) and neither have the same issue. I'll try getting Doomsday running in a different DE just to verify it's not related to my desktop environment though!
  • how long have you used kde before? cause it might hold the old alt modifer from past releases
  • I've been using KDE for a few years but only recently changed my gaming rig to it. You might be on to something. In "System Settings -> Window Management -> Window Behavior -> Window Actions", Alt is set as the modifier key for changing what mouse buttons do (never used or knew about this functionality). I'll test this and post again as soon as my desktop is back up. Thanks again for your input!
  • Yeah, I had that same issue in the past. Gnome used to use "alt" as the modifier key but now it's changed to the "super" key. but because I had just upgraded every release, it kept the old settings
  • Welp, I finally got my desktop back up. Turns out the "Windows Actions" didn't seem to make any difference. Messing around further, I noticed if I release Alt before Shift, it seems to work like a sticky key so that if Alt is bound to strafe, my direction keys would function as strafe until I'd press the Alt key again. When I get another chance, I'll try installing a different DE to see if that makes any difference and post again.
  • I've tried the IceWM and MATE Desktop Environments as well as trying a different keyboard but all with the same result. At this point I have a feeling it has something to do with the current Doomsday version used in the OpenSUSE Leap repos but I can't say for sure. Eventually I'll probably try installing the most updated version from a direct RPM but in the meantime, if anyone else has any experience with Leap and Doomsday, I'd be interested to know if they're experiencing the same issue.
  • Welp, I came back to this and sure enough, Ubuntu and Kubuntu, on different computers, exhibit the same issue on v2.1. I'm probably going to open a bug report but if anyone else can please confirm or dispute my finding, I'd greatly appreciate it.
  • Doesn't seem to be an issue for me (ubuntu 18.10)
  • DOH! Well I have no idea what I could possibly be doing to cause this to occur on multiple distros/computers but I guess I'll keep testing to see I find a combo that doens't exhibit this issue.
Sign In or Register to comment.