Slide Skyboxes mod not working [solved]

Hi all,

I was wondering whether you could help, basically I am trying to get the Slide Skyboxes mod to work with Final Doom, Doom 2 and Ultimate Doom using Doomsday 2.0.3 but none of them are loading when initiating any of the Doom games. Any steps in troubleshooting this issue would be much appreciated.

Kind regards,



  • edited 2017 Aug 24
    Either you need to setup a folder were Doomsday is supposed to look for add-ons, or you can use Doomsday's data subfolder (e.g. C:\Doomsday\data\).

    To setup a specific add-on folder click on "Packages" at the very top of the Doomsday main menu, then choose "Configure Data files", finally click "Add folder" and select your add-on folder.


    Now extract the contents of into your add-on folder, you should end up with a new subfolder "slide-skyboxes" containing thirteen .PK3 files representing the different Doom skies.

    Back in Doomsday choose your DOOM game (for example Ultimate DOOM (BFG Edition) ) and click on the "Packages" button.


    Activate the add-ons you want to play from the add-on list. If you have many add-ons, you can filter for specific add-ons by using key words like "Doom" or "sky" (as in the screenshot below) or a combination of keywords. Activated add-ons are listed below the game title image. Finally click "Play" below to start your game with the activated add-ons.


    Selected add-ons stay activated, next time you want to play your game with the same setup you can start it directly from the main menu.
  • edited 2017 Aug 22
    Hi deus-ex,

    Thank you for your response. I have tried each of the file paths below for the Slide Skyboxes mod with of course following your instructions but the Slide Skyboxes mod still doesn't initiate when launching any of the Doom titles.

    H:\Program Files\Doomsday 2.0.3\data



    H:\slide_skyboxes resulted with 2 errors when launching Doom 2 with the Slide Skyboxes mod but after restarting Doomsday and re-initiating Doom 2 with the Slide Skyboxes mode the errors disappeared.

    Would providing you with any log files help?



    P.S. The H drive is for programs and data.
  • Yes, please post your log file, maybe there's a hint in there.

    To post your log file use this function:


  • @deus-ex :+1: Good instructions!

    @RocknRollTim I can also take a look at your doomsday.out log, it should have something helpful in there. You can also attach it as a txt file if you change the file name to doomsday.txt (".out" is not accepted by the forums), or if you compress it with Zip.

    You should be able to find the log file in "C:\Users\{username}\AppData\Local\Deng Team\Doomsday Engine\runtime".
  • @deus-ex Thank you also for posting your good instructions.

    @skyjake Thank you for also responding to my forum thread as well as your good instructions.

    I have attached a copy of the doomsday.out log for you both to have a look at and to suggest any fixes that may help.

    Lastly I would like to apologise for not getting back to you sooner and appreciate you both helping me out.


  • edited 2017 Aug 24
    I cannot find anything in your log-file hinting for a problem. Maybe your integrated graphics processor hits a limit when activating this addon? Hopefully skyjake can come up with an idea. This will probably require some advanced debugging.
  • Thank you for all your help deus-ex, I shall await for skyjake's response. Would it help if I posted my system specs? My PC does have 2 graphics cards but currently using my integrated graphics card for my primary display.
  • edited 2017 Aug 24
    It sure does not hurt to take a look on your system specs.

    I recommend CPU-Z for the task. No installation required when downloading the zipped version which contains executables both for Windows 32 and 64 bit.

    Start CPU-Z and it automatically runs a short analysis of your system. Once finished, open the "Tools" menu at the bottom and select "Save Report as .HTML". Finally ZIP up the report and post it here.


    Alternatively you can take screenshots of just the more relevant CPU-Z tabs: CPU, Mainboard, Memory and Graphics.

    Here's an easy how-to:
    1. start CPU-Z and select a tab
    2. press [ALT+Print] (not just [Print] !) to take a screenshot of the current CPU-Z tab
    3. open a random image in a graphics editor, MS Paint is fully sufficient
    4. paste your screenshot [SHIFT+V] into the image and save it to a new name
    Repeat these steps for all relevant CPU-Z tabs. Finally ZIP up the screenshots and post the archive here, or upload your screenshots to an image host to post the images. I recommend
  • Hi deus-ex,

    I have attached the system specs report as requested using the first set of instructions in your last post. If require any further information from me please drop me another post.


  • Alright, let's hope skyjake can spare some time to investigate. Your system report should be helpful to clarify whether any of your system hardware is a limiting factor.

    A couple questions that came to my mind reviewing your Doomsday log and system report that might help understanding where the root cause of your issue might stem from:
    1. Please confirm whether you are able to play DOOM using the Doomsday port at all.
    2. Have you successfully been using any add-on pack other than the slide-skyboxes?
    3. From your CPU-Z report I gathered you are using a second display (Dell E2011H 20") beside your main display (AOC WJ1780PI 17"). Which display do you use to play Doomsday?
    4. Have you tried to run Doomsday on the other monitor, too?
    5. Regarding your two graphic display adapters, a Intel HD Graphics 4000 and a NVIDIA GeForce GT 620, you are running Doomsday with Intel's integrated graphics processor. Have you tried running Doomsday with the NVIDA adapter, too?
  • edited 2017 Aug 26
    Hi deus-ex,

    Thank you for getting back to me so promptly, below are my answers to the series of questions.

    1. Able to play DOOM without add-ons using the Doomsday port.

    2. Previously used the DOOM High-Resolution Model Project thinking it was the same as Slide's Skyboxes and found that it only made objects 3D and not both objects and enemies which I got working and deleted afterwards.

    3. Primarily use the Dell E2011H 20" to play Doomsday.

    4. Have done and the results are the same as the Dell E2011H 20" i.e. Slide's Skyboxes not initiating.

    5. Tried running Doomsday with the NVIDIA adapter and again the results were the same as in answer 4.

    Only a thought but does it matter where Doomsday and the add-ons are situated? My Doomsday install is currently situated in H:\Program Files\Doomsday 2.0.3 and the add-ons are currently situated in H:\slide_skyboxes.


  • Only a thought but does it matter where Doomsday and the add-ons are situated? My Doomsday install is currently situated in H:\Program Files\Doomsday 2.0.3 and the add-ons are currently situated in H:\slide_skyboxes.
    No, it shouldn't have an effect where Doomsday is installed vs. where the add-ons are loaded...

    I checked the doomsday.out you posted, and it seems everything was loaded successfully. The skybox PK3s were loaded without error messages, and it says you have 6 skies and 18 3D models available.

    If you type "listfiles" in the console, it will tell you which files are in use. The skybox PK3s should be included in the output.

    IIRC, there are no configuration options that disable skybox models. This means that if the PK3s were loaded, they will be used for rendering.

    This is what the Doom II map01 sky looks like with the add-on successfully loaded:

    (And for comparison, without the add-on...)
  • edited 2017 Aug 26
    Having limited access rights to a defined folder surely can make a difference, but that does not seem to be the case here.

    Your log file states that Doomsday loads the defined sky add-ons fine. However when Doomsday is about to initiate the game it terminates it right away, though without any error. That's what makes it so difficult to understand what the problem is.

    I made an optimized pack of Slide's DOOM-Sky1 for testing:
    1. download the attached file "slide-doom-sky1 (deus-ex)"
    2. remove the extension ".zip" from the filename
    3. drop "slide-doom-sky1 (deus-ex).pk3" into Doomsday's subfolder "\data ". It should be accessible in Doomsday without any further setup
    4. select it as the only active add-on for DOOM and see if it works
  • @skyjake I have entered "listfiles" in the console and got the log output below.

    Loaded Files (in load order):
    (basedir)\data\doomsday.pk3 (18 files, startup)
    Total: 18 files in 1 packages

    I figure it is using all 13 PK3s from H:\slide_skyboxes and all 5 PK3s from H:\Program Files\Doomsday 2.0.3\data excluding deux-ex's optimised pack of Slide's DOOM-Sky1?

    I have also tested Doom II map01 with and without the add-ons and got the same results as you which the add-ons are working correctly.

    @deus-ex I have also followed your instructions and performed the same tests as suggested by skyjake except using DOOM map01 in which the add-on also worked correctly.

    So from what I can gather the Slides Skyboxes pack was only meant to provide smooth rendering of the sky for each level and not the 3D rendering of objects and enemies? My question now is which pack provides 3D rendering of objects and enemies?

    I apologise sincerely for this guys, I should have spotted this earlier.


  • edited 2017 Aug 26
    As the name of that add-on suggests it provides enhanced visuals for the representation of the sky, nothing else. So if I got you right Doomsday did not crash at all for you? You just thought that the add-on wouldn't load? If that is so I consider the issue as solved. Please edit your first post in this thread and add "[solved]" either in the front or to the end of the thread title and then resave your post.

    In order to have 3D models of enemies and objects in DOOM you want to download the "DOOM Resource Pack (jDRP)" add-on.
  • You're right deus-ex and forum thread is already marked as solved. Thank you to both you and skyjake for all your help.


Sign In or Register to comment.