Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Original DOS iwad to Steam iwad

edited 2015 Oct 3 in DOOM
I have initially reported a troublesome in the Technical Forum but I haven't receive any real answer yet. I have no trouble joining my own server but I still have difficult joining other people's servers, even when I use the correct build (which is 1.15.2). My question is: Could it be related in the different version of the iwad. What I do have is the original DOS iwads from Ultimate Doom and Doom 2. I do not have the Steam version and I was wondering if the majority of your good people are using the Steam version. It may me wondering why some people can not join my server since I use the original DOS iwads. I do not know if it does make any difference of which version. But it would be nice to know for sure. Thanks.

Comments

  • The BFG Edition and Dos Iwads are indeed different and hence can't play MP together (well, the Doom2 Iwad in particular).

    Officially, Dday doesn't actually support the BFG Editions Iwads (it is perhaps the only major port not to have added support for them, due to an upcoming rewrite of the game mode area of the code). But I believe there are only a couple of non-fatal issues with the BFG Doom2 Iwad, so one can still the BFG Iwads under Ddays Ultimate Doom and Doom2 game modes, even though they are meant for the Dos Iwads.
  • Vermil, thanks for the quick response. I do have the BFG versions as well and I have tested it with the DOS iwad previously. It does work. But as far as the Steam version which I believe is why I cannot join other people's servers and vise versa. Now, I think I understand why other people having trouble joining my server (plus I have a Pwad added to my server as well). Thanks again, Vermil. I will probably limit the time in setting up my own server then (what's the point). I never had issue with the Zandronum port which I had some people joined successfully with the Pwad added as well. So it looks like I'll be setting up that server more often than Doomsday (unfortunately). :|
  • I don't 'think' it is indicated anywhere, but Dday checks the CRC values of Iwads to check they match the servers. I admit that I can't remember if it outright blocks users with different CRC values from joining or simply warns them when they join. Naturally, the Dos and BFG Iwads have different CRC values.

    It may well be that Zandronum doesn't perform such a check.
  • Just out of curiosity, I bought the Steam versions into my collection. It seems the Steam versions are the same as the DOS versions (I have checked the length of file size--they are the same). I have tried joining a server using the Steam version but still failed to join other people's servers with the correct build. This is puzzling why I cannot join and vise versa (why people cannot join my server). I was wondering if anyone else has this issue. I have noticed they are some active servers on the forum but I cannot see any indication if others have tried to join the servers (except the older builds). I know The Doctor and I can still play with the old build which is 1.10.4 (his computer could only play this version now since his computer is not that powerful to run the recent build of the Doomsday Engine). One of the main reasons why I haven't setup a server to the master server for awhile now. It's no big loss for the buying the Steam versions to test this theory (I have bought the Master Levels in the bundle which I didn't previously have). It looks like I will be setting up the Zandronum server more often. It's a shame because I want to join and play the Doomsday Engine for the models and such.

    Once again, has anyone else has this issue?
  • no tho i have not played mp recently.
  • edited 2015 Sep 21
    I have physical and non-BFG Steam Iwads and indeed, they do look the same to me. So I wonder what Dday objects to about them being able to play together.
  • As far as multiplayer is concerned, what matters are the IWAD CRCs, the game mode and the Doomsday net protocol version. If you are using the built-in network game browser then the first two should be taken care of automatically (I'm not sure the protocol version is checked in that UI). So long as you are loading the same IWADs (and any optional PWADs specified by the server) then you should be able to join such a server if it's using the same net protocol version.

    The net protocol version is incremented independently from the Doomsday build and version numbers. Meaning, it is not necessary to use the exact same version of Doomsday so long as they use the same net protocol.

    ---

    @GhostGuy - are you sure you have opened the necessary network ports for communication in your firewall(s)? To me, your issue sounds like a communication problem.
  • @DaniJ - The ports are opened. I have no problem joining my own server. My brother, The Doctor, and I can still play together which at moment we still use Doomsday Engine 1.10.4 build now. However, when I try to join other people's servers with the recent builds, no luck (when I also use the recent builds). I do not see much activity for other people's server anyway so it's no big deal. As long I'm able to join my own server is what's matter now. Thanks for the response. I had been away on a trip to respond earlier.
Sign In or Register to comment.