Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Doomworld wad "Endless Torture"

edited 2015 Apr 29 in DOOM
The following wad from Doomworld doesn't load E1M1 with Doomsday:
http://www.doomworld.com/vb/post/1365494
It's a megawad for Ultimate Doom called "Endless Torture".
For some reason the first episode "Cybernetic Nightmare" won't start with Doomsday Engine! Any ideas why?
Thanks in advance!

Comments

  • what dday build are you useing as it worked for me.
  • I'm used to working with 1.14.5 and even tried the latest unstable version.
    It's strange because each level of this megawad is loading fine besides the first one!
    With another source port I tried the level loads correct.
  • it loads fine for me tho i need to try the latest unstable if there is one from the version i have.
  • The following file causes the problem:
    "jdrp101+11a+fixes.pk3"
    Without loading that file everything works fine!
    Thank you for your help!
  • np glad i could.
  • I took a look at this problem and its nothing at all to do with the jdrp101+11a+fixes.pk3 add-on. Using this add-on in combination with ET simply reveals an issue elsewhere (i.e., its a symptom rather than the cause).

    The actual problem lies in the internal node builder's interpretation of the geometry comprising/surrounding sector #89. Examining the map in an editor reveals that there is only a single two-sided line with this sector number. However, it is not "free standing" and does in fact split sector #23 in two. Clearly the node builder is being confused by this set up. Is this some kind of map hack?
  • i have no idea but looking at the map it seems it's an oversight on the map maker.
  • That was my interpretation also but to be sure I asked datacore over at Doomworld and he confirmed that it is indeed an oversight.

    Now I need to figure out how to deal with it :)

    Edit: I've now found the cause of the problem and am currently preparing a fix. It turns out the nodebuilder is actually handling it correctly, the issue lies in the surface decorator working at line / sector level rather than with the convex subspaces.

    Edit2: Now fixed for the next unstable build.
  • edited 2015 Apr 29
    @ DaniJ
    Thank you so much! I really appreciate your effort!
  • wads will always show up as doom witch is something that has never been properly addressed but you can still load it via the -file command line augment.
Sign In or Register to comment.