Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Memento Mori

edited 2012 Sep 6 in DOOM
Has anyone been able to successfully run the Memento Mori wads for Doom 2 using the Doomsday Engine? There are two wads, mm.wad (maps) and mmmus.wad (music) in a zip file called mm_allip.zip, which can be downloaded from http://www.doomworld.com/idgames/?id=4855. It looks like mmmus.wad loads up in DE just fine, but mm.wad does not. When I unload and load mm.wad from the console, a lot of messages like the following are displayed:

Invalid Patch nnn in texture definition "xxxx", ignoring.

The game doesn't load the maps contained in mm.wad but instead starts off at the first level of doom 2 with the music of mmmus.wad.

I tried loading both wads using a clean install of Doom 2 ver 1.9 running in dosbox and both loaded without any issues. Has anyone run across this before and are there any workarounds?

Thanks

Comments

  • I can run both Memento Moris just fine in Doomsday 1.9.7 or newer. In fact these add-ons are two test cases I use regularly during engine development. How are you running it?
  • Hey DaniJ-

    I simply put the mm_allup.zip in the Doomsday\snowberry\addons folder and selected it from the Doom 2 addons tab. I'm running DE 1.9.8-1 (Stable 32-bit #543) with Jdoom 1.16.1 on Windows 7 64bit. I should also mention that I've tried Memento Mori 2 and it works OK.

    I've attached my doomsday.out file. I'm not familiar with all of the console commands. Let me know if there are any commands that I can run that would be helpful.

    Thanks!
  • @ crom
    I note you are loading Memento Mori 1 from two places at the same time; the auto folder as extracted wads and also as a zip through Snowberry.

    That said, with the latest unstable build for Windows, I can confirm that Dday isn't loading the maps from Memento Mori 1, both when the wad is inside a pk3/zip and extracted.

    Doomsday is displaying the menu graphics and level names etc. But it's not loading the maps themelves. The seperate music wad appears to load fine.
  • Hi Vermil-

    Thanks for verifying. Yeah, I couldn't get it to work by extracting the wads from the zip file either. Then I thought there may be something wrong with the wads so I tried it using a clean install of Doom 2 v1.9 running in dosbox and it worked OK, so I concluded that the wads were OK and it was something with DE. The unloading/loading of the wad via the console was just me playing around trying to isolate/reproduce the issue so that I can upload the log for the devs to see.

    Thanks!
  • It seems to be the lack of marker lumps around the new texture lumps, inside MM.wad, that is preventing Dday from loading the maps; MM.wad has no markers around it's new texture lumps.

    I added PP_START and PP_END markers around the textures and Dday stared loading the maps.
  • Thanks Vermil-

    I'm not familiar with the structure of a wad file. How did you add the markers around the textures? Also, is this something that DE should be able to handle, i.e. is it a bug that should be fixed in a future release, or will I have to manually edit the wad file like you did?

    Thanks!
  • I've found the source of the problem, its due to logic in the WAD file loader intended to translate the lump names of the Mac Hexen demo. A fix for this issue will be in the next unstable release.
  • So my rebuilding the wad to add those markers, was removing all that garbage data from the lumps, that was causing the problem?
  • There was an issue in the engine's .wad file loader that misinterpreted the lump names in the original version of MM.wad (see: http://deng.git.sourceforge.net/git/git ... af53ffe07a).
  • I notice that it is easy to get stuck in a lift or elevator if I step onto it as it raises and get stuck in the ceiling or wall, making it a requirement for me to use -noclip to escape. I wonder if that is a problem with this wad or a problem with the latest build.
  • I can confirm an issue with lifts, though not exactly what Garry states.

    If the player is standing on the edge of a lift when it begins to raise and proceeds to hit his head on a ceiling, the lift will correctly reverse direction.

    However, if the lift has already started moving before the player moves to a position that causes him to hit his head, the lift will not reverse direction and instead just stop.
  • Yeah, this is a new regression. I've already found the cause and it will be fixed for the next build.
  • Maybe it was just lifts. Not sure.
Sign In or Register to comment.