Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Custom step1 texture and step1 flat are conflicting (Solved)

edited 2012 Jul 27 in Technical Support
Today I realized that the Doom texture named "step1" shares the name of the flat of the same name. The problem with this is that doomsday looks for custom textures and flats in the same folder. Is there a simple work around to allow doomsday to recognize the texture named "step1" as being different from the flat "step1"?


  • Dday does support a seperate folder for flats, called, er, 'flats'. (i.e Data/JDoom/Flats).

    If you want to have your flats and textures together in the textures folder though and you have one with a conflicting name, add 'FLAT-' to the start of the flat's file name. I.e 'FLAT-STEP1.PNG'.
  • I did originally have a separate folder for flats. I renamed the file the way you suggested (flat-step1) and it didn't work. I then tried "flat_step1" (changing the "-" to"_") but that didn't work. I then tried "flat-step1" and put it into the "textures" folder and it still didn't work. Any suggestions?

    Edit: not sure if its important but what is happening is the engine is using the texture for both the texture and the flat. So the flat looks like a stretched out version of the texture "step1".
  • I have just tested this myself and the high resolution replacement of the step1 flat and wall texture is working correctly when using the DHTP add-on (available here:
  • I've just tested it as well, with the latest unstable build, by sticking a graphic named STEP1.PNG into flats and a different graphic named STEP1.PNG into textures. They both displayed fine.
  • I realized what I was doing wrong and now i've got it working. I had all of the "Textures" sitting directly in the pk3 but then I had a folder named flats with the flats inside it. In other words it was like having the "flats" folder inside of the "textures" folder. Doomsday read the other flats just fine so I didn't think anything was wrong but in the case of "step1" I think it was still seeing them as being in the same folder. I fixed this by actually creating two separate folders (".../textures" & ".../flats"). Amazing how a drive through the country can clear a persons mind. Thanks guys.
Sign In or Register to comment.