Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Monsters too fast in coop after setmap? Can't disable Respawn? Setmap does'nt work?

Hi.
I'm trying to play the second episode of Doom 1 Ultimate in Coop - Mode.
My autoexec.cfg:
net-ip-port 13209
server-game-coop
server-name "Coop!"
server-game-skill 4
server-game-coop-respawn-items 0
server-game-coop-noweapons 0
server-game-coop-nodamage 1
server-info "Come join my game"
server-player-limit 8
server-public 0

My .bat to start the server:
doomsday-server.exe -game doom1-ultimate -iwad ..\wads\doom.wad -p \configs\doom1co\autoexec.cfg

I can start the server and join the game, but

1) Munition, Heal Potions and Armor does respawn. I thought "server-game-coop-respawn-items 0" should prevent this.

2) Setmap 2 1 and server-game-map X does not work in the autoexec.cfg. Doom starts always with E1M1. I can only set the map 2 1 in the console of the doomsday shell. Works, but

3) The monsters are way too fast, especially the imps and cacodemon fire rate and speed.
The shell says after setmap
"Sending game setup: doom1-ultimate 2 E2M1 dm2 jump"
dm2 is deathmatch 2, right?
My config seems to be overwritten. And the gamespeed is real hell, no chanco of survival...

I hpope somenone can help me.
Greetings from Germany
Ralf

Comments

  • Here's a .cfg that should work:
    net-ip-port 13209
    server-game-deathmatch 0
    server-game-episode 2
    server-game-map E2M2
    server-name "Coop!"
    server-game-skill 4
    server-game-coop-respawn-items 0
    server-game-coop-noweapons 0
    server-game-coop-nodamage 1
    server-info "Come join my game"
    server-player-limit 8
    server-public 0
    

    Co-op mode is enabled with "server-game-deathmatch 0".

    Note that the variables for specifying the starting map are quite finicky at the moment: you'll need to set both the "server-game-episode" and "server-game-map" variables, and also make sure that the map is specified as the full form "E2M2" instead of just a number. The episode number in "server-game-episode" must also match the map ID.

    I'll make a note to do something to improve those cvars for 2.1...
  • Thank you, starting in E2M1 works now.
    But the Monsters are still too fast. The Demons have almost the same speed as me, the Imps and Cacodemons are firing like machine guns.
    Btw, im using Ver. 1.15.8
    Ralf
  • edited 2017 Oct 15
    I believe 'server-game-skill x' takes 0-4 and not 1-5. Hence 3 is Ultra Violence, 4 is Nightmare etc.

    Is there a reason for this Skyjake?
  • Yes, setting the skill Level to 3 does the trick!
    Never played on Nightmare before. It's really awesome.
    Thanks for helping me.
    Ralf
  • Vermil wrote: »
    I believe 'server-game-skill x' takes 0-4 and not 1-5. Hence 3 is Ultra Violence, 4 is Nightmare etc.

    Is there a reason for this Skyjake?
    The reason is that the cvar values match the internal enumerations used in the code, so no additional translation is needed (which might introduce bugs). Most of this kind of value ranges are zero-based internally.
  • Vanilla Doom's '-skill' command line option accepts values 0-5, with 0 placing no mobjs on a map other than the player start. 1-5 correspond to the in game skill levels.
Sign In or Register to comment.