Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

250ms mouse lag, how do I fix this?

Does everyone who plays this mod have 250 milliseconds of mouse lag at all times? I just reinstalled this after a 6 year hiatus, out of curiosity I checked my last doomsday (Doomsday Kickstart 2.09) from around 2009 or so and there's no mouselag. I do remember high particle counts causing occasional spikes of mouselag in 2.09, but generally it was normal. It's a real shame because this mod looks great apart from this huge problem. I tried disabling anti-aliasing and v-sync, to no avail. I'm surprised there's no other posts here noting this issue, is the solution so obvious I missed it somehow? I find it hard to believe everyone here is universally willing to accept 250ms of mouse lag at all times. If I can't fix it I will unfortunately have to ditch the mod.

Only other thing I can think of is I play with a gaming mouse and the high polling rate might be overwhelming what the executable can handle... I'm going to try this next. Doesn't make sense that 2.09 would be fine though.

Comments

  • edited 2017 Apr 28
    It definitely isn't normal to have that much latency in the mouse input. None of my development systems (Windows, Mac, Linux) exhibit such issues.

    I suspect the problem is indeed related to your mouse. I assume you're on Windows? At the moment, Doomsday uses regular window events to receive mouse input instead of using any low-level API for this purpose.

    I have it on the roadmap to use a different input API on Windows, but so far there have been more pressing issues to work on.

    You can reduce latency a little by disabling mouse filtering and switching off the 35Hz vanilla input mode. These settings can be found in the Input Settings dialog.
  • Can verify polling rate and Synergy(the mouse&keyboard sharing program) are not the problem... For anyone searching this years later, you might want to use a cursorlocking program/method or disable Synergy while playing Doomsday, as Synergy will take cursor priority over Doomsday, and the transition will kill the cursor in your current session. (This is something synergy users need to deal with, Doomsday devs shouldn't worry about this problem)
  • Thanks for the prompt reply, tried using a spare mouse, had no effect. Disabled the mouse filtering, not sure where the 35hz vanilla input setting is, doesn't seem to be in the same place. Also tried lowering the resolution. All had no effect. If the baseline scenario is doomsday 2.0.0 has more mouse lag than other doom mods, it could be that my tolerance is just lower than other doom players. The delay amount is extremely consistent, It's hard to estimate but I'd guess it's at least 100ms, maybe 200ms high end estimate.
  • Sorry about the late reply, but you can find the 35Hz setting here.
    24hvpyhjrvlu.jpg

    It is admittedly quite well hidden... :blush:
Sign In or Register to comment.