Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Doomsday 2.0 low framerate issue

When I use Doomsday 1.x in a large area, like in the large room in The Gantlet in Doom 2, I seem to stay at a nice solid 85fps... Looking at MSI Afterburner my GPU usage is pretty good and my card's core clock goes into gaming mode and memory clock goes to 3Ghz like it is supposed to.

In Doomsday 2, same room, I get 19fps, and my GPU is staying in low power mode, like it's not even being utilized. I did use a utility that set my GPU to use full power at all times, it did nothing to the framerate and GPU usage was almost 0%.

I'm not sure what's going on there, or how to fix it.

Comments

  • I was going to post detailed information of the Doomsday.out files and DxDiag but they are too large to post.
  • i7-4770K CPU
    16GB RAM
    GeForce GTX 780
    Microsoft Windows 7 Home Premium 64-bit

    Here are my specs, at least. :)
  • edited 2017 Apr 22
    Are you using any addons?

    The problem is likely not related to your GPU. While the renderer in Doomsday 2.0 is not exactly optimal in terms of CPU/GPU usage, and generally the performance has been sloping downward recently, it shouldn't be that bad as to go from 85 to 19 FPS.

    Seeing your doomsday.out might give some clues why the performance is so slow. You could use zip to compress it, that should make it small enough to post here.

    Renderer performance will be a focus area in upcoming 2.x releases. In general, though, the current "classic renderer" that has been written with OpenGL 1.x in mind (long time ago...), will be largely untouched in favor of more modern GPU techniques that require OpenGL 3.3 or later.
  • Ah ok. The thing that got me was the fact that, for some reason, Doomsday 2 wasn't bringing my GPU out of idle speeds, leading me to think that, perhaps, it wasn't using it for some reason... I'm going to try some GPU driver stuff to see if it's on that end, then I'll zip up the files.
  • Alright after doing more testing and fiddling around with my video card settings, you're right, I'm getting more like 68fps instead of 85, so it's just a mild decrease rather than severe.. I'm not sure which setting it was, but now my GPU core clock actually goes up to gaming level now when Doomsday 2 is loaded. I also unselected and re-selected my addons. So it seems to be working normally.. Thank goodness!

    I'm sure those frames will come back with the newer releases.
  • Now I feel like an idiot.. When I unloaded my addons and added them back I selected the old JDRP file I had been using with the glitched Pinky Demons... Apparently jdrp101+11a+fixes.pk3 is just a framerate killer.

    So now I'm back with my original problem.. Glitched Demon models. Oh well. That's better than a bad framerate! :s
Sign In or Register to comment.