Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

[Windows] Doomday #2287 and #2288 crash

Hi Skyjake,

Thought I'd give you a heads up. Both builds #2287 and #2288 crash on startup - earlier versions load up fine.

Here's the doomsday.out contents - it's short but may give you a clue.
Application path: C:\Games\Doomsday\bin\Doomsday.exe
Build: 2.1-Unstable [#2288]
Created a new 32.0 MB memory volume.
[Config::read] /packs/net.dengine.stdlib/modules/Config.de is newer than modules/Config, rerunning
               the script
               Detected new build: 2286 => 2288
Detected SteamApps path: c:\games\steam\SteamApps\common
Using user-selected WAD folder: C:\Games\WADS
Using user-selected package folder (including subfolders): C:\Games\WADS\Addons
Executable: Doomsday Engine 2.1.0 [#2288] (Unstable 64-bit) Apr  8 2017 03:14:09
Command line options:
  0: C:\Games\Doomsday\bin\Doomsday.exe
[RenderSystem > PackageLoader] Loading shader definitions from archive entry "renderer.pack/
                               shaders.dei" from archive in "(basedir)\data\net.dengine.client.pack"
                               Loading shader definitions from archive entry "renderer.pack/
lensflares.pack/shaders.dei" from archive in "(basedir)\data\net.dengine.client.pack"

Thanks,
Bob.

Comments

  • At least 2288 works fine for me... (Windows 10 Pro 64-bit)

    Did you use the MSI or ZIP installer? Which version of Windows are you using, and have you verified that your previous build 2286 still works normally?
  • I'm running Windows 10 Pro 64-bit too. The update for #2287 was downloaded via the auto-updater. #2288 was downloaded and installed via the MSI package.

    I haven't gone back to check #2286 yet so I'll do that when I have a little more time. I only play occasionally so I'll come back to you when I've tried that.
  • I have a small update on this. I went back through the versions individually getting to #2282 and they all exhibit the same crash.

    I know for definite that #2283 was working so something must have changed at my end but I'm not sure what as I don't believe I've changed any settings or installed any new packs.

    I've deleted the contents of the cache folder which didn't help. I've also moved my entire Addons folder elsewhere to see if that had an effect, but sadly no. I also tried moving my WADS folder (containing all game IWADS) somewhere else to eliminate a possible issue with one of them but the same results were observed.

    I ran Doomsday.exe from the command line with the -vvv switch and I've included the last few lines of doomsday.out below. Just to point me in the right direction, what lines in the log file would come next if all was working fine?

    Thanks,
    Bob.
                window.     __source__:0x420005
                            __type__:  group
                            background.__notInBank__:True
                                       __source__:   0x420006
                                       __type__:     image
                                       path:         graphics/background.jpg
                            borderglow.__notInBank__:True
                                       __source__:   0x420007
                                       __type__:     image
                                       path:         graphics/borderglow.png
                            cursor.    __notInBank__:True
                                       __source__:   0x420009
                                       __type__:     image
                                       path:         graphics/mouse.png
                            icon.      __notInBank__:True
                                       __source__:   0x420008
                                       __type__:     image
                                       path:         graphics/window.png
    [DefaultGLFormat] New format is the same as before
    Initializing plugins...
    [Library] Loading "(basedir)\bin\plugins\audio_directsound.dll"
    [~Library] Unloading "(basedir)\bin\plugins\audio_directsound.dll"
    [Library] Loading "(basedir)\bin\plugins\audio_fmod.dll"
    [~Library] Unloading "(basedir)\bin\plugins\audio_fmod.dll"
    [Library] Loading "(basedir)\bin\plugins\audio_winmm.dll"
    [~Library] Unloading "(basedir)\bin\plugins\audio_winmm.dll"
    
  • edited 2017 Apr 9
    Something else I forgot to mention - I uninstalled Doomsday, cleared out the contents of the installation folder and then reinstalled it. This had no effect.

    [Edit: I also have a CrashDump file that is generated if that would be of use; I've attached it here.]
  • edited 2017 Apr 9
    It could be that there's an error reported somewhere earlier in the log file. Could you zip up the whole doomsday.out and attach that, too?

    Have you tried reseting your configuration? Try renaming your runtime folder so that it gets recreated and see if that has any effect.
  • I renamed the runtime folder and launched Doomsday with the same result. I've attached the verbose (-vvv) doomsday.out file here.

    Out of interest, I haven't checked the source code but do the log entries get flushed to disk as soon as they're written? I ask the question because I wondered if the crash might cause the log file to be cut off prematurely... I'm confident it's not the case but I've seen that happen previously in my career.

    Thanks.
  • Hmm, I don't see anything alarming in the log...

    However, right about where the log ends, it would go into OpenGL initialization. Perhaps there is something going wrong with that. What kind of a GPU is your system using, and are its drivers up to date?
  • It's running dual GTX-670s in SLI and drivers are up to date. I tried disabling SLI too as a couple of games I've played recently don't like that but no change. I'll try rolling my drivers back to a previous version as there was an update recently.
  • So I downloaded build #2295 and the problem seems to have been solved so it's a mystery to me! Thanks for looking into it with me.
Sign In or Register to comment.