Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

[macOS] Doomsday 2.0 crashes at start

I downloaded Doomsday 2.0 and when I launch it I get the splash screen before it crashes completely. Running the binary from the terminal prints
Illegal instruction: 4
I am running 10.11.6 on an early 2009 iMac (2.66 GHz Intel Core 2 Duo, 8 GB 1067 MHz DDR3, NVIDIA GeForce 9400 256 MB). Is my machine or OS too old for 2.0?

Comments

  • edited 2017 Apr 4
    This error suggests that the compiler flags currently used on macOS aren't quite right. I'm targeting 10.10 or later, but this is via CMake so I'll need to verify that the correct options are used when compiling.

    I can try making a manual test build after I check the options, so you can try it out.
  • edited 2017 Apr 4
    Here's a build for you to test: https://www.dropbox.com/s/n2esc21gdx1z8qo/doomsday_2.1.0-build2284_x86_64.dmg?dl=0

    You can run it straight from the disk image.

    I've built this one with the macOS 10.11 SDK.
  • The same thing happened.
  • edited 2017 Apr 6
    I was looking around some more and I believe I've found the problem. The FluidSynth audio plugin uses two libraries that have been built for macOS 10.12. This should be fixable as I can rebuild those libraries...

    EDIT: Tracker issue https://tracker.dengine.net/issues/2242
  • Please try tomorrow's build (Friday 7th). I've now fixed the FluidSynth plugin so it targets the correct version of macOS. Also, I've tested the build on my old Late 2009 iMac running macOS 10.11.6.
  • skyjake wrote: »
    ...
    Thank you, it works now. My performance is <30FPS now, before 2.0 it used to be >60FPS. Is that to be expected?
  • On a very general level, renderer performance is likely down a bit on average in 2.0, but not by that magnitude. See my comment in another thread for some details.

    The game window composition is being done differently (rendering everything to a texture first), which will cause problems on slower GPUs as they need to do an extra copy of the entire window.

    One possible reason for unusually low frame rates that I've noticed on my old 27" iMac is that due to the high resolution and relatively slow GPU, it is quite limited by fill rate. It helps the performance a lot if you drop Pixel Density in Renderer Settings. Alternately (or additionally), try disabling antialiasing and the Bloom effect (cvar "rend-bloom"). Those are the biggest hits on fill rate.

    For me, I can get ~60FPS if I use Pixel Density 0.5 with AA + Bloom enabled in fullscreen. The AA compensates quite nicely for the halved resolution.

    (My Mac has an ATI Radeon 4850.)
  • Thanks, resolution was the choking point for me. I'm now playing in a window, I can almost stretch it to fullscreen 1980x1200 while maintaining 60FPS, but not quite. It's good enough for me now. I prefer the vanilla look, I like my sprites blocky.
Sign In or Register to comment.