Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

compile only server

is it possible to somehow compile only server binary on freebsd without lot of dependencies??

Comments

  • Currently a dedicated server uses the same binary as a regular Doomsday instance. It is not presently possible to build a "cut down" version for use as a dedicated server. This is something we intend to address over the course of the 1.9.x series.
  • any progress on that?
  • You can nowadays compile the server only by giving qmake the "CONFIG+=deng_noclient" option. That will exclude all the GUI/client components from the build.
  • unfortunately there is no appropriate switch in freebsd ports ...

    ===>>> The following actions will be taken if you choose to proceed:
    Install games/doomsday
    Install archivers/zip
    Install audio/sdl_mixer
    Install audio/libmikmod
    Install audio/timidity
    Install devel/sdl12
    Install devel/nasm
    Install graphics/aalib
    Install graphics/libGLU
    Install graphics/libGL
    Install archivers/gtar
    Install devel/bison
    Install devel/m4
    Install devel/gettext-tools
    Install devel/libdevq
    Install devel/makedepend
    Install devel/xorg-macros
    Install graphics/libdrm
    Install devel/libpciaccess
    Install misc/pciids
    Install graphics/libglapi
    Install lang/python2
    Install textproc/py-libxml2
    Install devel/py-setuptools27
    Install x11/dri2proto
    Install x11/glproto
    Install x11/libXdamage
    Install x11/damageproto
    Install x11/libxshmfence
    Install x11/presentproto
    Install x11/libXxf86vm
    Install x11/xf86vidmodeproto
    Install devel/qmake4
    Install devel/qt4-corelib
    Install devel/qt4-moc
    Install graphics/qt4-opengl
    Install x11-toolkits/qt4-gui
    Install devel/qt4-rcc
    Install devel/qt4-uic
    Install devel/xdg-utils
    Install misc/hicolor-icon-theme
    Install x11/xprop
    Install x11/xset
    Install x11-fonts/libXfontcache
    Install x11-fonts/fontcacheproto
    Install print/cups-client
    Install x11/libXcursor
    Install x11/libXinerama
    Install x11/xineramaproto
    Install x11/libXrandr
    Install x11/randrproto
    Install net/qt4-network
    Install net/sdl_net

    ===>>> Proceed? y/n [y]
  • Yeah you would have to build manually from source to use that qmake option...
  • ok, any list of all required dependencies??
Sign In or Register to comment.