Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Black screen at game startup but game running

edited 2014 Jul 8 in Technical Support
Got a strange issue here. Whenever I launch a game from the front-end, it launches the game and plays it but it leads to a black screen. I can hear the game and the sounds in the background and even navigate menus and play, but I can't see a thing. However, if I Alt+Tab to the desktop and then back to the game, the screen image appears and I can see. It's only upon the start-up of the game that the screen goes black. This happens with every game I use in Doomsday Engine.

Only thing I can think of is some sort of video driver and Doomsday specific problem. I recently updated my graphics drivers so that I could play a game that depended on updated drivers and Doomsday hasn't been updated in ages. I'm just wondering if there's a way to resolve this in another way besides updating Doomsday.

There aren't really any errors, but I can supply any information you may need. This happens regardless of any addons installed.

- Doomsday Version: 1.12.2
- AMD Radeon R9 270X
- Driver version: 14.10.1006
- CCC Version: 14.4
- Windows 7 Home Prem SP1 64-bit
- 16 GB RAM

Thanks.

Comments

  • Try opening the taskbar and toggling the vsync setting?

    Dday has some difficulties (similar to what you describe) when it has to toggle it during game start up. Hence it's best to make sure all the games and such are set to the same vsync setting.
  • I don't understand why vsync on is set as the default? I find that on my comp, vsync off works the best. In fact, on every game that I own, old and new, they run better without vsync.
  • Vsync is on by default because screen tearing is really ugly and it completely ruins the immersion. Although I must say that the last time I used an ATI video card that I too had to disable vsync. As usual YMMV.
  • I appreciate the responses but I don't think that's it. I have vsync already disabled, I'm pretty sure I do anyway. My refresh rate is 60Hz but I get 125.0 FPS constantly pretty much in Doomsday. Is there a way to boost it past 125, or rather to uncap it? I've had it set this way since before this problem began. Something changed in-between then and now and the only thing that happened that was major was a video driver update. I was going to try re-installing Doomsday with a newer version sometime soon to see if that fixes it.
  • Found the problem.

    For some reason, having Antialias OFF in the video settings causes the game to have a black screen at startup, but the game is still running. Likewise, switching between on and off causes a black screen to remain until you cycle through windows and back to the game but the game remains playable.

    Turning Antialias ON and restarting the game allows a proper startup with no black screen. Odd because I had it off before and it was always fine. Perhaps updating the engine may fix the problem causing the problem.

    I knew it was a config problem because I tried removing the config for Doom first and tried a fresh new startup, and it worked.
Sign In or Register to comment.