[Solved]Multiple public server issue (ubuntu linux)

edited 2018 Oct 1 in Technical Support
Hello everyone,

I'm trying to setup multiple public server on the same physical server.

If I start 1 server, everything is fine, server info get pushed to the master server list.

Then if I start a second one, it will overwrite the first server on the master list.

If I start all of them at the same time, none of them get pushed to the master server list.

with the doomsday-shell-text, i monitor those server, and i don't have any error messages from the master server.

They all have their own separate ports, from 13209 to 13215

here's my config :

the line with the # sign are called by cron when the system boot.

Any help would be appreciated, and will result with nice & fancy server in north america :)


  • There shouldn't be any fundamental issues preventing multiple servers on the same machine, so we should be able to figure this out. :smile:

    My first guess is that the servers you start are using the same runtime directory, so they are identified as being the same server. Try setting a unique runtime directory for each server instance with the "-userdir" option.

    In other words, add something like "-userdir ~/.doomsday/server{NN}" to the command line options.

    As a side note, Doomsday comes with a Python script that helps manage multiple servers, although it is now slightly outdated after we moved to CMake. Nevertheless, for reference: https://github.com/skyjake/Doomsday-Engine/tree/master/doomsday/tools/host

  • I added the userdir variable, they now have their own directory, but the result is the same.

    When i enabled only 1 server at a time, i saw they were all being advertised on port 13209 on the master list. The weird thing is when I check the shell, they seems to be on their proper port :

    | * Connect to... |
    | Disconnect |
    | localhost:13209 (Doom2 Canada Server; 0/8) |
    | localhost:13210 (Heretic Canada Serve; 0/8) |
    | localhost:13211 (Plutonia Canada Serv; 0/8) |
    | localhost:13212 (TNT Canada Server; 0/8) |
    | localhost:13213 (Hexen Canada Server; 0/8) |
    | localhost:13214 (Hexen DK Canada Serv; 0/8) |
    | localhost:13215 (Ultimate Doom Canad; 0/8) |
    | Start local server |
    | Scroll to bottom F5 |
    | About |
    | Quit Shell Ctrl-X |
    F9:Menu >

    Right now, The hexen server seems to be the advertised one, but we can't connect from the multiplayer tab because the server is listening on port 13213 and the master list think it's 13209. What I see in the list right now : ::ffff: and should be ::ffff:, right ?
  • Also, regarding the script to manage server, i checked the doc, but couldn't understand the required dependency package required. But it seems to be a nice tool.
  • I tried only 1 heretic server with port 43002, on my lan i see the server on port 43002, but on the master list, it's still on 13209 (default) port. I also tried to specify the port with my launch with "-port 43002" but it's still the same.
  • edited 2018 Aug 9
    If the advertised port is somehow the same for all of the servers that would certainly explain why the master server is only seeing one of them...

    For what it's worth, I just tried starting a server via the Shell GUI app on macOS and a custom port was correctly announced to the master server. The same works for me using the -port option.

    I'll have to redo this check later on Linux, though. Perhaps there is a platform-specific issue.
  • edited 2018 Aug 10
    I just tried on a windows 10 pc with the same config, and it seems to work perfectly with a random port.

    So ... yeah I guess this is a bug that is affecting linux only.

    edit : I opened this bug : https://tracker.dengine.net/issues/2277
  • I believe I found the cause of this problem. Please check the next unstable build or latest master branch.
Sign In or Register to comment.