Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Ridicolous framerate on my mac

Hello there, I'm a huge Doom fan and thanks to this engine I can play it again on my macbook (15", from 2013, i7, integrated graphics card and 8 gb of ram).

Unfortunately the frame-rate is below 15 fps, with few monsters it drops to below 10...now, I understand my mac is not a gaming machine, but we are talking about a game from 1996...how is that possible? Is there a way I can remove any graphic pack/overhead (for example I notice that the lighting is differente from the original game) and restore the original version of doom? It might help with lowering the graphics load...

Any tips is well welcomed! Thank you

Comments

  • Sounds like the default settings of the renderer are too much for your GPU.

    There are a few options you can tune depending on which version of Doomsday you're using. When running a game, press Shift+Esc and find this menu: https://manual.dengine.net/_detail/file/pixel_density.jpg?id=guide:configuration

    Try changing the Appearance to "Vanilla (built-in)". This will disable all the effects. If this helps, it is also possible to make a custom appearance profile with only some of the effects disabled. For example, the Bloom effect is particularly heavy for old GPUs.

    Alternatively or additionally, try reducing Pixel Density. This will reduce rendering resolution but should give a nice speed boost.

    Also check that the Antialiasing setting is disabled in Video settings.
  • The "vanilla" option help me a lot, now the game is super fluid with the original graphic! Thanks Skyjake!
Sign In or Register to comment.