v2.1+ Changing "Audio Backend" "Output" does not work.

I build Doomsday Engine from source on Ubuntu 18.04.2

For the most part, everything works. However, when I have a USB headset plugged in (thus multiple "output" options) things go awry. I haven't seen any other posts, so I'm not sure if there's something unique to my environment, or if it's just not common for people to have multiple output devices.

As a shorthand, I'll call the audio output I want to use "speakers" and the one I don't "headset." If I set the system output (Ubuntu) to "speakers" then when I launch doomsday, "speakers" will be the selected "Output" (as expected) - however, the sound will actually come out of the "headset" (not expected). If I close Doomsday, and change the system default to "headset" then launch Doomsday, the "Output" is set to "headset" - but the sound will come out of the "speakers."

There's oddity one - in a nutshell, when I have two output options in Doomsday, the sound comes out of the one that's not selected.

The second oddity is that I can't use the "Audio Backend" configuration menu to make a change to "Output." If I select the "Output" option, it will list my choices. However, once I select a different one, I don't get an "Apply" button. It's as if I didn't change anything. If I change this and something else, I'll get an "Apply" button, but using the "Apply" button does not actually save the change made to "Output." I can go right back into the settings, and the original output device is still listed as the selection.

At current, my only options to get sound to come out of the "speakers" is to either unplug my USB headset before launching doomsday or set the system default to "headset" before launching doomsday.

I tried this on the 2.1.0 release, the 2.1.1 release, and also the latest build (3129).

Comments

  • edited Jul 29, 11:43
    Is it a pulse audio problem?

    arch wiki might have some info, even though you are using ubuntu
    https://wiki.archlinux.org/index.php/PulseAudio/Examples#Simultaneous_HDMI_and_analog_output

    if you use gnome, an extension might help?
    https://extensions.gnome.org/extension/751/audio-output-switcher/
  • KuriKai, thanks for the links. I reviewed the details but I do not think they will help. The selection for the audio output at the OS/pulse level works without issue for the system. It is only the selection that's within doomsday that's not working as intended. Not only does doomsday output to the wrong device (even though every other app and OS output to the correct device), the selection UI within doomsday is also buggy and does not hold a selection as I change it nor let me apply the change.
  • I tested the audio output briefly in Ubuntu 19.04, and there is certainly something off there. For me, FMOD audio output was being distorted.

    I'll dig up a second audio output device and do more testing.
  • edited Sep 12, 11:27
    This (or something very similar) is happening on Windows 10 1903 as well.

    In my particular case I have two outputs... a discrete sound card I use for my headphones, and hdmi out which I use for my speakers. I normally control which is the active output by simply switching the default device in Windows 10. After switching to headphones for some late-night gaming and starting doomsday everything was fine. However, after switching back to speakers the following morning and starting doomsday, doomsday continued to output to the headphones regardless of the default in windows or the configured output in doomsday. I eventually had to disable the headphone output in windows (and restart doomsday) to fix it. Deleting persist.pack accomplished nothing.
  • In fact, it seems if I re-enable my headphone output... doomsday goes back to using it automatically. Even if it's not default in Windows.
  • The latest patch from MS to the Win10 1903 update has created a number of new problems. One is with the sound in certain games.

    I do not know if this is your problem or not but a Google search on this might add more useful info.

    Good luck,
  • I appreciate the response. Unfortunately, if this is a compatability issue introduced by the 1903 update... then it still falls to Doomsday to implement a fix. That said, given that there are many threads with similar issues going back before the release of 1903... and this thread where someone using linux is having the same apparent problem... I'm disinclined to think this is related to the 1903 update.

    But like I said, I do appreciate the response. You're literally the only response I've seen on these forums so far.
Sign In or Register to comment.