Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Updated 2.0.3 to 2.1.1 : incompatible mods

Hello!


I recently updated Doomsday from 2.0.3 to 2.1.1 version (same folder), on Windows 7 x64.
First time I loaded 2.1.1 version, a "Fix" option appeared, so, to fix it, I had to reload all stuff (textures/models/ui/music) for each game.
P.S.: the addons folder remained untouched, since I've only updated Doomsday version running its executable (msi 64 bit): this means that all stuff (textures/models/ui/music) is exactly the same as 2.0.3 version (I have a backup copy of that folder, containing WAD, PK3 files and *.BOX subfolders, and it's identical).

But, despite this, now I can't load 2.0.3 savegames due to this error:
97azzy81fgpm.jpg
What happened?

Comments

  • 2.1 fixed a few bugs in the processing of mod metadata, including version numbers. Since the old save game specifies the old versions, Doomsday thinks you don't have the right ones.

    What you should try is to just force-load the save after you've made sure that the right mods are loaded. Check the "ignore incompatible/missing mods" checkbox there in the pop up and you should be able to proceed with the loading.

    The next time you save the game, it will have the right mod versions saved with it.
  • Thank you very much.
    Loading savegames ignoring incompatible/missing mods works and so the "issue" is bypassed.

    I also noticed that weapons appear differently in 2.1.1 (especially the chaingun, graphically very different), using the same mods as 2.0.3 version, since I haven't changed anything except DoomsDay version.
    Why?
    (2.0.3 chaingun appearance is much more similar to the original Doom one).
  • Could you post a screenshot of the different chaingun appearance?
  • skyjake wrote: »
    Could you post a screenshot of the different chaingun appearance?

    Here you are:
    kvnvle2yu5t8.png 2.1.1 (and 2.2) chaingun

    e598o18kh7jx.png 2.0.3 (and earlier versions) chaingun

    Same mods, same configuration
  • I had the same problem but I updated my 2007 version of DHMP to the 2018 version and this solved the chain-gun rendering problem for me.
  • John wrote: »
    I had the same problem but I updated my 2007 version of DHMP to the 2018 version and this solved the chain-gun rendering problem for me.

    I'll try DHMP 2018 instead of JDRP 2007, with 2.1.1 / 2.2 version
    (maintaining a 2.0.3 copy installed too, with JDRP, just to have all working in any way)
Sign In or Register to comment.