Dengine doesn't accept sprites with HUD weapons from pk3

edited Jan 6, 12:21 in Technical Support
I created hires textures for Hexen. Engine picked up everything but HUD sprites (weapons) is not. I can't understand why. I put it to the Patches folder but no results. Please help.
i89t3grz1zb6.png

Comments

  • Hi,

    are there any error messages? Have you named the images correctly....

    can you post your pack?
  • 0815Jack wrote: »
    Hi,

    are there any error messages? Have you named the images correctly....

    can you post your pack?
    All entires named correctly (as it is acording original wad names)
    Tested other mod in Heretic and no problem there.

    Hexen pk3
    https://drive.google.com/open?id=1j1uhl14gi_RhPu8OWPwJ-rMmMLHGHmgc
  • In the latest stable release, the HeXen hud weapons display fine for me.

    Though it reminds me that Ddays smart hud weapon positing doesn't seem to position the sprites correctly in 16:9 aspect ratio.
  • edited Jan 19, 16:33
    Vermil wrote: »
    In the latest stable release, the HeXen hud weapons display fine for me.

    For me too. I tried the pack with Hexen and the latest release and noticed corrupted white entries to recesses when glass was broken at the beginning of the game but mostly everything looked fine in small part I tried. Good work, I would not mind even higher resolution as I play on big 4K tv but it is still very good as it is. Grandgreed, how much of your pack is completed and is it recommended to play the game with it in the current state?

    nnm8m1.jpg


  • works me for as well except the glitch J345 noted...

    are these textures created from scratch or upscaled ones using NeuralNetworks or somegting similar....
  • edited Jan 20, 19:01
    Indeed these are upscaled textures derived from the original images:

    ahtw7o7y3py6.jpg
    It's no surprise that this upscaled texture does not work in game, it's a 24-bit image and thus lacking the alpha channel information. I re-added the alpha channel and edited the image to remove the undesired gray shimmering from the glass edges.

    Finally I optimized the file size using my special tool chain. I could convert the image to 8-bit to decrease its file size even further while keeping the transparency info intact, but I figured I release the 32-bit variant if anyone wants to edit it in a image editor for some reason:

    55bldaxa9bf5.png

    Download the archive attached below to obtain the optimized texture, saving the image I posted above results in increased file size.

    Enjoy yourself.
  • edited Jan 21, 00:46
    Yes, it fixed it, thanks. I am currently at Shadow Wood and also noticed this:
    - some items and also Stalker when freezing are low-res
    - some switches looks quite blurry, especially SW_OL
    - there is white color glitch when shooting to some windows (screenshot of this is from Darkmere)
    - similar problem is when shooting hedge in Sacred Grove:

    xqgx1j.jpg

    2m62xoi.jpg
  • You need to address these issues with the maintainer(s) of the addon, there are not related to the Doomsday engine.
  • Yes, I posted it here as he started this thread and maybe will read it.
  • edited Jan 23, 13:08
    Corrupted textures with transparency fixed. But white effect is not a package issue. GZDoom and old Doomsday engine hasn't such problems.
    can394cr9223.png
    qws3gpvc3y82.png

    J345, please make some screens of low-res when freezing and with switches.
  • edited Jan 22, 10:55
    grandgreed wrote: »
    Corrupted textures with transparency fixed. But white effect is not a package issue. GZDoom and old Doomsday engine (Kicks 2.0.9) hasn't such problems. J345, please make some screens of low-res when freezing and with switches.

    Here they are.

    oietr6.jpg

    2qxbaiu.jpg

    The chain and handle in switch are quite blurry as well as freezing Stalker silhouette. The game with this Neural upscale pack looks great but I think that some parts still need some additional processing and improving. For example Dark bishops could be a bit sharper too and also some rocks look not too good and natural and straining the eyes when playing. I added for comparison picture of cave05 from your upscale pack (the surface resembles rather fish scales than rock) vs Hexen Community Compilation Pack.

    2rgf5g3.png

    2vwtzb6.png

  • J345, thanks for answer.
    The main purpose of work is to restore the original textures to a higher resolution without loss of detail and without using filters. If different filters are used, such as sharpening, there is a risk of appear white contours that makes psycho-visual perception of sharpening. This is a parasitic effect. Next. Adding fake details with a bump map from your example is unacceptable, only close view of what was conceived by designers since the beginning. No intervention, only the original.
    About blurry textures. Just compare what it was and what became. Processing method allows to get only the result that is possible, no more no less. Do not forget that there is a ceiling above which not to jump. The method allows to get quality only where it is available.
    Missing sprites and high color map will fix soon. Thanks for observations.
    wbdugnbpwtvw.jpg
    eei4w891m4h5.jpg

  • edited Jan 22, 13:31
    Yes, the rock is definitely more faithful to original. I do not think it should be changed as much as in Hexen Community Compilation Pack, however as I wrote I would prefer a bit more natural look of it and even better resolution. But I understand it is very difficult task with such a low-res source and that there are limits to what you can achieve. Still the game with your textures looks overall better than with any other pack I have tried so thanks for your work.
  • J345 wrote: »
    there is white color glitch when shooting to some windows (screenshot of this is from Darkmere)
    - similar problem is when shooting hedge in Sacred Grove
    Which version of Doomsday are you using? This might be a bug in the recently revised light blending shaders.
  • edited Jan 23, 15:49
    Doomsday 2.1. I tried the savegame with community pack and also without any upscaled pack at all and the problem persisted so it looks like bug in Doomsday.
Sign In or Register to comment.