Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

remapping of DualShock 4 issue

edited 2018 Dec 13 in Technical Support
I have problem with remapping of DualShock 4 in options - controls of Heretic. Immediately after pressing enter joy-w or joy+w is written (without pressing anything on controller) and I cannot change it to something else as the program doesn't react to controller pressing. Is it a bug or am I doing something wrong?


  • How does the controller behave in game if you just use this preset?


    Don't forget to press the "Apply" button after selecting PS4. That will create the bindings for you.

    You may need to adjust the deadzone of the axis that is misfiring. For instance, try this in the console "input-joy-w-deadzone 0.2".


    Unfortunately these settings are currently not easily adjustable in the GUI... Better gamepad support is on the todo list.
  • It seems a bit redundant to call the option 'Xbox one/360 (360 controller)'?

    Why not just 'Xbox one/Xbox 360'?
  • It refers to a macOS-specific custom gamepad driver called 360Controller.
  • edited 2018 Dec 13
    If I use preset PS4, controller works in the game but binding does not suit me. Specifically turn left and right. Default PS4 turn left is: joy-x joy-z, turn right: joy+x joy+z. So it is strafing and turning at the same time on left stick. There is probably some bug when applying presets. I need turn left: joy-z, turn right: joy+z. I solved it for now by editing bindings.cfg file.
  • I do not have the input option under the settings menu as depicted above in skyjakes post... also my xbox controller is not being recognized ingame. It does nothing when I try to bind keys, or when I press keys in game. Plus for some reason it does not recognize my doom 1 or doom 2 wads. I opted for complete installation. What did I do wrong??
  • I don't usually play Doom with a controller, but I have an Xbox One controller hooked up and noticed both turning and sidestepping are both bound to the left analog stick by default, which seems like a mistake? There are also multiple keys bound to fire by default.
  • edited 2018 Dec 19
    @Vermil The only gamepad defaults that work 100% correctly are the presets set via the Input Settings dialog, although it's a bit buggy still in build 2900. The duplicate axis bug is being worked on:
  • skyjake wrote: »
    work 100% correctly

    a bit buggy

    To clarify, the presets define the correct bindings for all buttons and axes, but the bug is that some of the pre-existing bindings are not cleared when the correct ones are applied.

Sign In or Register to comment.