Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Issues getting any game to launch

I'm trying to do DOOM II coop with some friends but I can't get anything to work properly. Pre Dengine 2.0, I successfully got DOOM II to work without any problems, but this new iteration is very unintuitive to me. I've selected my IWAD folder (I'm using the DOOM 3 BFG editions of DOOM 1 and 2) and it recognizes on the packages half of the screen that I have those 2 WAD files, but I'm unable to launch DOOM II. When I try to load the game I get "game "doom2" is missing one or more required packages: file.pwad.doom2_0.2016.902.2015."

I added doom2.wad to DOOM 2: Hell on Earth, but I believe I've added the DOOM.wad to it as well and can't find a way to un-add. I've tried reinstalling/resetting dengine to start back at square one, but dengine seems to remember everything I've done between installs. I can't find anything relevant on the wiki or in the guides anywhere after hours of searching and I've about given up on getting this working. Any help would be appreciated.

Comments

  • The BFG edition IWADs are only recognized in the 2.1 unstable builds. Have you given those a try? They shouldn't be that unstable atm.

    If it says "file.pwad.doom2" that means it thinks the DOOM 2 WAD is a PWAD, which is incorrect.
  • Thanks for the suggestion. I just tried it out and I'm getting the same results. My friends that I was going to play with all have the same issues.

    Is any other step required besides finding the WAD files? Nothing shows up when I click "Play In..." and I can't load a game in the console either. On old builds before they had this screen split down the middle, they let me run games as soon as I've pointed Doomsday to the WAD files. I'd play on the old builds but it didn't seem like I would be able to play online with friends on them.

    34dnwzzhsf8u.png

    7kt3w0tegyd9.png
  • I have the same problem after trying to add an addon folder than had a subfolder with spaces in it. Considering some addons wouldn't load if it spaces in it; and this is a problem with the path, as in Doomsday can't find the folders at all, and the fact certain addons wouldn't load before without removing spaces form the filenames, I'm recently certain this is the culprit.

    Solution: you need to find that whatever configuration file for your older Doomsday exists and delete it so Doomsday can do everything from scratch and no longer has however it stored path not correctly in them. (I myself can't for the life of me figure out where and what the file is, looking through every doomsday folder I can find including in local data in user folder, there's nothing that jumps out at me. Part of the reason for my above topic.)

    Anyway, if that solves the problem, go through your folders and remove spaces in folder names before adding them again.
  • edited Sep 23, 17:18
    Okay, so here is what should be the solution: uninstall doomsday, then delete the following folder:
    c:\Users\%username%\AppData\Local\Deng Team\
    

    Then reinstall Doomsday; that should allow Doomsday to go properly find the games, and show up again.

    Before you add any addons or games, check whether there are any folders or filenames that have space in them, and replace those spaces with underscores. The automatic "check folders for addon's/games" routine does not work with spaces in filenames and folder names; somehow it messes up the database entries with I'm guessing a wrongly placed "end-of-filename" and everything following tries to start checking paths in the wrong part or something.
Sign In or Register to comment.