Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Wad path problems

To start off, I am a noob with this new version of dengine. With that out of the way, this particular iteration is not only causing extensive frustration but also borderline-rage. It seems as though I have far less control than when I last tinkered with dengine. I have bought doom multiple times. From the collector's edition, to the steam and gog editions.

What I usually do is quickly install the steam versions to snag the wads and create my own doom-hub. I am finding this to be quite harder this time around then if I just used gzdoom and doomlauncher (or a bat-file system). When using this version of dengine, it always defaults to the steam directories and will not recognize the wads in any other directory even if I used the package tool. I can find no way around this at this time. I have tried many things. even putting the wads into the base dengine directory. It will not show.

Granted I actually have no problem playing when it auto-defaults to steam install but that isn't the point. I want the ability to control where this frontend reads wads like the old snowberry system had. If anyone has any idea on how to tweak this so that I can design my directory structure on my terms, then it would be appreciated.

Comments

  • Sorry to hear about your troubles. While Doomsday 2 automatically recognizes Steam/GOG installs, it will still prioritize the -iwad command line option, and the paths configured in the Data Files settings.
    it always defaults to the steam directories and will not recognize the wads in any other directory even if I used the package tool.
    What do you mean by "package tool"?

    In Doomsday's game library, have you opened the task bar (Esc) and added your IWAD paths to ⚙ > Data Files > IWAD Folders?
  • the package section where it allows you to specify iwad folders. It seems to recognize most of the wads in the base directory. The one I am having the most trouble with is ultimate doom. It still prioritizes the steam version and only that one, even if I copy the wad out of the base directory into the special directory that I made.

    How would I go about doing this in the command line? Last couple of times I tried I kept getting unknown identifier error. I know I am doing something wrong, probably in the realm of bad syntax.

    I tried doing it with the designate iwad folder, but weird things happen, it will for instance, pick up all the master level wads, and even the strife1 wad I dug out of my veteran's edition. it will somehow pick up the bfg edition wads (in the steam directory and in an experimental directory), but It will not show any of the main wads like DOOM.WAD, DOOM2.WAD or even the hexen wads. I even tried to rename them.

    I would just like to be able to go and browse into a folder and assign a wad to a game like the earlier versions, really. It just seems like the process became entirely convoluted instead of intuitive, and it seems it was all for the sake of attempting automation of processes in exchange for the loss of fine-tuning and control.
Sign In or Register to comment.