Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

Linux & Oculus DK2 & Doomsday

Hi,

i would like to use doomsday (which is awesome :smile: ) with the oculus dk2 under linux.
As i understand i need to compile it by myself including the libvr stuff. I have the SDK for the oculus 0.5.1 up and running.The Demo runs perfect. I cloned the git repo of DE.
I have also been able to set all using cmake-gui. I am linking against Qt5.8 (is that a problem?) i have also tried Qt5.5.1. I am always getting Error when compiling within libappfw:

/Doomsday-Engine/doomsday/build_main/apps/libdoomsday/src_libdoomsday_turbo.cpp: In member function ‘de::StringList GameProfiles::Profile::unavailablePackages() const’:
/Doomsday-Engine/doomsday/build_main/apps/libdoomsday/src_libdoomsday_turbo.cpp:2221:6: error: no matching function for call to ‘filter(de::StringList, GameProfiles::Profile::unavailablePackages() const::__lambda13)’
});

There are some more afterwards, but this is the first error which stops compilation. :neutral:
I am running Linux (which is actually a Linux Mint 16):
Linux 3.19.0-32-generic #37~14.04.1-Ubuntu x86_64 x86_64 x86_64 GNU/Linux

Hope someone can help, because i like Doomsday very much and would be happy playing all the games again using VR.

Thanks in advance!!!!

Comments

  • I stopped updating Doomsday's VR code at LibOVR 0.5.0.1 beta. This was around November 2015, so I believe your best chance is to try an older version of Doomsday.

    For example, 1.14.5 or 1.15.5 might do the trick. These older versions were built with qmake, so it's a bit different to configure them. The wiki has some instructions about it.

    There are plans in the Tracker about updating the VR code now that the VR SDKs have matured somewhat.
Sign In or Register to comment.