Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Doomsday crashing all the sudden. [monitor refresh rate change]

I got a new video card (1080 Ti) and loaded up Doomsday, tried it out to see how it played in some areas that lagged previously, found it to run much better, then exited.

I decided to restart it to try out another addon, and now it just makes the screen turn black for a few seconds, then crashes with the message "Doomsday.exe has stopped working".

Another thing I noticed is, I always run at 85Hz. Trying to run Doomsday forces 100Hz. Even the old 1.15.6 version of Doomsday (which still works) now forces my display to 100Hz.

I can only imagine Doomsday 2 munged it's settings file but I'm not sure where it's located.


  • Updated to 2.0.1 and still crashes.
  • Doomsday.out says it failed to initialize OpenGL.. For some reason it worked once, after that, it fails every time.

    Doomsday 1.15.6 still works, everything else I have that uses OpenGL works.

    I also deleted the whole Deng Team folder in /appdata/local/ and Doomsday 2 will run ONCE. Then it will crash the next time it's opened, until I delete the directory again.

    I'll delete files one by one in the original folder until I figure out which file it is.
  • Okay this is what I figured out.. If I have my desktop set to 85Hz, Doomsday 2 will run ONCE, switch my video to 100Hz, and run fine.. When I quit, the next time I start it will crash every time unless I delete \AppData\Local\Deng Team\Doomsday Engine\runtime\persist.pack

    If I change my desktop to 100Hz and run Doomsday 2, I can quit and reload it as much as I want. Basically if Doomsday 2 has to change my monitor frequency setting to start, persist.pack keeps it from running in subsequent attempts.
  • Thanks for the detailed report. There may indeed be an issue with the display refresh rate/mode switching — I haven't tested it recently on Windows since I usually just run it in the same display mode that the Windows desktop uses.

    Are you still on Windows 7 Home Premium 64-bit?

    I'll run some tests, although I only have Windows 10 running on actual hardware...
  • Yes everything else is the same, except I swapped out a GeForce GTX 780 for a GeForce GTX 1080 Ti with the latest driver.

    4770K/16GB RAM/GeForce 1080 Ti/ BenQ XL2720Z 27" 144Hz monitor/Windows 7 Home Premium 64-bit/ 382.53 Geforce video drivers
  • I swear that Doomsday used to just run on the 85Hz.. I'm not telling it to switch it.. I want it to run at 85Hz... Maybe you can add that as an option, setting from 60-144Hz or "Use Current Desktop Mode"?
  • Doomsday already defaults to using the desktop resolution, but perhaps there is a bug in that it doesn't default to the right refresh rate? I'll check.
  • Theoretically the Nvidia driver might also be upping the refresh rate to produce a better game experience, although I'm not sure if such an option currently exists in the driver.
  • More information: Okay, I tried several resolutions and found out Doomsday will not run at at any Hz value I had to create as a Custom Resolution for in the nVidia settings. It will only run at the ones the video card detected when the drivers were installed (50?/59?/60/100/120/144). I don't seem to have this issue with any other game, but it might just be some change in the way the nVidia drivers interact with OpenGL.

    I do know, however, with my old card, it ran fine at 85Hz. Unfortunately I can't roll back since the old drivers don't support the new card. :(
  • skyjake wrote: »
    Theoretically the Nvidia driver might also be upping the refresh rate to produce a better game experience, although I'm not sure if such an option currently exists in the driver.

    Well there is an option to set that basically sets the refresh to "Application Controlled" or "Highest Available" and the default is "Application Controlled".

    That setting was present on the old drivers also, and it worked normally.

    I did the Brute Force approach for now-- I write-protected "persist.pack".. I won't be able to save settings for now, but at least I'll be able to run without crashes!
  • The 2.1 unstable builds now have an option in the Video Settings for selecting the monitor refresh rate. That setting may or may not have an impact on the problem you were/are having. Let me know if something changes...
  • I tried out the 2.1 unstable. The game still starts at 100Hz, and when I check the setting, 85Hz isn't on the list.. But choosing any of the other ones just makes it go to 60Hz. I have to exit and reload to get 100Hz back.

    But at least it doesn't crash anymore!
  • Ok, thanks for testing. My current monitors only do 60 Hz so getting this right is slightly challenging. :smile: I'll try making some further improvements...
  • I just upgraded to Windows 10, and it fixed the issue with the framerate selection..... But now the game music is stuck to Microsoft's horrid default MIDI, and Doomsday ignores any custom soundfont I select. :(
  • Recent unstable builds now come with Fluidsynth. If you select FMOD for sound effects and Fluidsynth for music, it should allow you to use SF2 soundfonts for MIDI music.

    The default music settings have been changed to use the SF2 soundfont that is included in the "net.dengine.client" package (part of the installation).
  • This works, and changes the music in realtime to any soundfont I choose! Thanks!
Sign In or Register to comment.