Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Cannot assign keyboard bindings linux

Cannot assign keyboard bindings in linux. I have ubuntu 16.04 LTS 64 bit. Is it because i have a microsoft mouse and keyboard (yeah i know it's ironic being in linux with microsoft hardware).

Each time i try to assign control it's automatically assigning joy-x everywhere. Tried in DE doom 1/2.

I dont have this problem when i use freedoom 1/2 (prboom+)

Please help.

Comments

  • It sounds like the problem is that Doomsday is receiving input events from a gamepad/joystick device, or some other input device that it thinks is a joystick.

    Do you actually have a gamepad or joystick attached? If not, go to the Input settings and disable the game controllers settings. This will make Doomsday ignore those events.

    If you do have a gamepad/joystick and wish to use it, its deadzone settings need to be adjusted. I can give more info about that if you need it.
  • Input settings? Where? In DE GUI or in the loaded game settings. I Don't see input settings in DE... Can give you a screenshot if you want.
  • edited 2017 May 31
    Doomsday's Input settings are accessible via the DE task bar when a game is loaded. You can pop up the task bar by pressing Shift-Esc.

    i2z3f0p6bj6r.jpg

    For more information, check out this section in the Readme: http://dengine.net/manual/guide/2.0/man/doomsday#configuration
  • Thank you sooooooooooooooooo much!
Sign In or Register to comment.