Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Can't use the keyboard in Heretic

edited 2017 Jan 23 in Heretic
Hi there. I just downloaded version 2.0 build 2211 x64. Everything seems to work fine, I can load all packages (the hi res package for Heretic and the DOS music, just those two), but when I start Heretic, I press any key to make the menu appear, and after that, the keyboard stops working. I can't select anything or do any other thing besides pressing shift+escape to put the prompt and type "quit". If I start pressing the keys randomly, the arrow of the menu jumps to a different option, appearently randomly. But I can't select anything. This happens whether I start the game with the packages selected or not.
What can I do?
Thanks in advance!

Comments

  • DDay out file?
  • I have seen a similar bug myself a couple of times, although it seems quite random.

    Could you first check if your bindings are still intact? When you're in the game menu and it doesn't seem to respond, open the console prompt and type "listbindings". It should show all the bindings in effect, including the ones used to navigate the menu.

    If the list doesn't show any game-related bindings, try typing "defaultbindings" to restore the bindings.

    If the bindings are already in place, the bug is likely related to the Home UI. I've seen at least one scenario where a widget in the Home still has input focus and thus steals all keyboard input even though the game is already running. I'll have to investigate whether this can still happen; I've already applied a couple of changes to prevent that from happening.
  • The bindings were precisely the problem!! When I listed them, there only appeared four bindings!! So I typed defaultbindings, and relisted them, and then they appeared all of them. After that, the keyboard worked perfectly. I tried the game a little, no problem at all. Thanks a lot!!
  • Glad to hear! I also discovered another bug related to the focus-stealing I mentioned. That should be fixed in the latest build.
Sign In or Register to comment.