Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Music too fast (Ubuntu)

edited 2016 Oct 26 in Technical Support
In doomsday stable (1.15.8) and doomsday 2.0 the midi music playback is very fast (2x speed?). Works fine with doomsday 1.9 (and chocolate-doom), but I would like to upgrade from 1.9 because the load game feature doesn't work.

doomsday.out

Comments

  • Doomsday plays music via various 3rd party libraries, so I would expect the problem to lie in that direction.

    On Ubuntu, you should be able to use Fluidsynth or FMOD as alternatives for SDL_mixer. The latest 2.0 builds now support selecting the preferred audio plugins via the Audio Settings dialog. You may need to provide an SF2 or DLS sound font file (that contains the MIDI instruments samples).
  • I'm having the same issue. How can I select a different audio plugin? The audio settings don't show me any alternative. Also, when I start Doomsday, the console shows me this error message:

    Failed initializing driver "FMOD":
    [LoadError] (AudioDriver::load) Unknow driver "fmod"
  • Your build probably doesn't include the FMOD plugin. It is a closed source library and therefore only included in the binary builds on http://dengine.net/builds.

    Are you using SDL_mixer currently? Note that SDL_mixer itself has various backends for playing MIDI that Doomsday has no visibility to.

    I've found that FluidSynth offers the best music quality, given a good soundfont. On Linux, Doomsday has been configured to use the system FluidSynth library, which uses the system audio output for playback. Depending on which version of Doomsday you are using, FluidSynth can be enabled either with the "-imusic fluidsynth" command line option or in Audio Settings.
    Leprosy57 wrote: »
    The audio settings don't show me any alternative.
    Could you post your doomsday.out log and maybe a screenshot of what the Audio Settings dialog looks like, please?
Sign In or Register to comment.