Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Can´t figure out how to host own server for multiplayer game

edited 2016 Jun 25 in Technical Support
I installed 1.15 with add-ons. Single player works fine by executing doomsday.exe. If I execute doomsday-server.exe in my Windows 10, nothing happends. I´m able to launch doomsday-shell.exe and I there start new server, it thinks for a while and then I get "no playable games available".

I´ve hosted doom multiplayer games 2-3 years ago and I used shell fine, but now I see everything has changed. This is no help: http://wiki.dengine.net/w/Shell_Help

Comments

  • The Shell is the app used to host your games, yes. Check in the Shell Preferences that your IWAD folder is set correctly.
  • First, I tried to execute -iwad "C:\Program Files (x86)\Doomsday\wads" and nothing happends.

    Then I gone to Server->New Local Server -> Advanced -> Runtime Folder and set "C:\Program Files (x86)\Doomsday\" there. Now it hangs at "Starting local server..."
  • I´m still stuck at "looking up host" and that´s it. Nothing happends, and I don´t see "stop" or "running servers" available for me.
  • I figure this one out, the host cannot be run on Windows 10. It will be run fine on Windows 7.
  • just tested it on win 10 and it works fine with no addons. did you perhaps forget to set up port forwarding on the router?
  • No, I have directly public IP, no routing.
  • some cable/internet companies supply a router/modem combo so you would still need to check it. a good example here in canada is telus witch dose that.
  • Gordon wrote:
    some cable/internet companies supply a router/modem combo so you would still need to check it. a good example here in canada is telus witch dose that.

    I have a public IP adress and visibility to publish directly in internet.
  • can you access you modem? change settings if the answer is no then it is just a modem witch means your fire wall is blocking you. if you can change settings then it's a router/modem combo.

    Edit: i know that some os's like windows have a firewall that is turned on then the anti-virus software has it's own as well so be sure to check to see if one of them is not stopping it as well. if you are connected directly to a modem like you say then you should have no problems what so ever.
  • Dear Gordon, I´ve been working in ISP myself and I am an IT specialist, so there is no need to discuss network issues :)

    I´m behind public IP directly, that should tell you everything.

    ps. on Win7 it works, on Win10 doesn´t. Same network segment etc.
  • I´ve been playing MP on Dengine 3-4 years ago without any issues. Now since GUI and dedicated server config is rewritten, its just doesn´t work so well anymore as it used previously. I´m hoping developers will take care of this in next builds.
  • the thing is nothing has realy changed as i can host servers on win 10 and i am behind a router and you can't on win 10 and you say your directly connected witch i find it hard to beleave but will go with that. to get doomsday working in mp on win 10 is exactly the same as win 7. the only difference is drivers for some stuff might be causing the problem.

    also side note i may not be an it pro like you but i am no slouch ether as i have pick up stuff from the it in my family so when i say stuff it's what i know can happen and has happened to me.

    the last thing i can recommend to check is the Ethernet card drivers weather it's the onboard one or dedicated one as some times they also have a firewall that is not apparent. i am trying to help you but your setup is making it hard. lol.
  • Same time we play Duke 3D and Blood, hosting MP with not problems with the same setup. I use dosbox + meltdown for that.
  • do you have something witch can close ports installed? if so then switch dday to one that is open. this is the last solution left. else get a router.
Sign In or Register to comment.