Playing Heretic Cooperative multiplayer

edited 2015 Aug 22 in Heretic
Hi there. Here's the thing: I Have Doomsday Engine 1.14.3, and I'd like to play a cooperative multiplayer, like, for example, perfect dark saga, gears of war saga, etc. I'd like to start from level 1 of the first episode, and from there play the entire game cooperative. I've red in the wiki that, to play multiplayer, you need to create an... autoexec.bat (I believe that's what it's called) with all the options of the multiplayer to apply in the shell. So, to this end, could anybody please tell me what options do I have to put in the autoexec.bat? I want to play cooperative, without friendly fire, uhm... I believe that's it. The problem is, last time I tried the shell, I had to play each level separatedly, and I want to play all of them, with the weapons from the previous level, me and my friend. Like any cooperative game. Can this be done?


  • If you set up a shell and start a Heretic server, it should automatically start with Co op mode. When I played before, the players progressed level by level sequentially.
    I've got a server up at the moment if you wanted to have a go.
  • Sounds cool. How do I connect to your server?
  • Load Doomsday, load Heretic, go to multiplayer and choose the server.
  • ...load Heretic....
    This stage is no longer needed ;)

    Multiplayer games, for all games, can be accessed via Ring Zero or the Taskbar. When you join an MP game via Ring Zero or the Taskbar, Doomsday will automatically launch whatever game the MP game is for.

    However, changing your player name and skin colour still has to be done via the in game multiplayer menu.
  • Tea Monster, whenever I try to join your server, I get this error: ... retic.html

    What could it be the problem? If I start the shell, and then join my own shell, the game works. What could it be?
    BTW, what is Ring Zero?
  • Dday 1.15 builds are currently crashing when one tries to join an MP game.

    Ring Zero is the menu that comes up when one launches Dday without a command to launch a game. One can also reach Ring Zero by unloading an in progress game.
  • Ookey. So... I joined Tea Monster Server, but no one was there. And, also, I had to join from Ring Zero, because from heretic, it crashes, exactly like Vermil said. Main problem is, the only way to access ring zero is by unselecting the wad file of heretic. But, doing that, the engine didn't load the addons, I had to play entirely with the old graphics. So, how can I access Ring Zero, and then start heretic with all the addons loaded?

    Edit: Also, when I choose "end game" in the menu of heretic, it exits the engine, and returns me to the frontend.
  • I discovered how to enter Ring Zero: to start the engine without the frontend. Yes, I know that's the basics of the basics, but I didn't know how to do it :P . The problem is, I start Ring Zero and try to select any multiplayer game, but they all appear transparent, and I can't select them, any of them. So I tried to connect manually to Tea Monster server, but the engine crashed too. The error says something that it couldn't read E1M1 level. Ideas? I'd really love to play a cooperative heretic!
  • Try the latest unstable 1.15 build (1241); a crash issue relating to joining an MP game has been fixed.

    I don't think it should cause any issue trying to join an MP game using an earlier 1.15 build (it goes without saying though, that ideally it's best that one's build matches the host's).
  • I host the server, it dosen't necessarily mean that I'm on it.

    I've hosted it as I like Heretic and I hardly ever get to play MP. Unfortunately, I tend to have zero time to do anything like that at the moment. So I host it so others can have some fun.
  • I see. Thanks, Tea Monster. And, thanks, Vermil, I'll try that version. Thanks!
  • Oookey, I tried version 1.15 build 1241 and version 1.15 build 1260. Still can't play multiplayer. And error pops up. I don't have the log of the error, but the situation was the same: An error during an attemp to connect to another doomsday shell. The error doesn't happen if I connect to my own shell, it happens only when I try to connect to any other shell, not only with heretic, but with ultimate doom too. Any ideas?
  • And error pops up. I don't have the log of the error, but the situation was the same: An error during an attemp to connect to another doomsday shell.
    It would help to see what this error looks like. Maybe you could take a screenshot of it, or maybe even a photo of your monitor if nothing else works?
  • Currently Dday seg faults (i.e it's a standard seg violation message with no other info, as far as I am aware) when one tries to join an MP game and the server is using a different build to the player (naturally, one own server co-incidently tends to use the same version of the engine one is running).

    The info box about an MP game also doesn't list the build number, only the engine version. Given Dday's regular and official unstable builds, I would like to suggest such information be added?
  • Load Doomsday, load Heretic, go to multiplayer and choose the server.
    Thanks it helped us.
  • Guys i don't understand. When i go on multiplayer it says join game so i press that and then there are no servers there. Plz help me. T
  • Here is my server adress
  • edited 2017 Aug 5
Sign In or Register to comment.