Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Doomsday engine fail to start due to shader problem? [old HW]

edited 2017 Mar 29 in Technical Support
I have an IBM Thinkpad T60 laptop from 2007, specs as follow: Core 2 Duo T7600, Ati Mobility Radeon x1400 128Mb, 3Gb RAM.

When I try to launch doomsday engine, the following error message comes up:
"
[LinkerError] (GLProgram::link) Linking failed:
Fragment shader(s) failed to link, vertex shader(s) failed to link..
"
Is my laptop too old and is not supported? If so, then where can I find older versions of doomsday engine that could run on my hardware? I was soo looking forward to play again my childhood favourite games, but things don't look too encouraging soo far. Thanks for any help in advance.

Comments

  • It sounds like the GPU is a bit too old, yeah... You might have luck running one of these versions:
    • 1.12.2 (last one before post-processing shader effects were added)
    • 1.11.2 (first to require OpenGL 2; not many shaders used yet)
    • 1.10.4 (last one with official Windows XP support)
  • THANK YOU VERY MUCH!!!!! The 1.10.4 release works just great. I am so glad I can play them again, and wow, this engine really boosts up the visuals, and mouse support too. I was about to use DOSbox to emulate these games, but using this engine gives a 1000 times better and smoother results.

    Thank you again!
Sign In or Register to comment.